You are not logged in.

#1 2013-02-16 01:43:17

mmix
Member
Registered: 2012-10-03
Posts: 42

[TIP] Upgrading portage fixed masked pygobject.

https://trecko1234.appspot.com/pastebin.com/2kxn4mfu

Calculating dependencies... done!

!!! All ebuilds that could satisfy "dev-python/pygobject:3[python_targets_python2_6(-)?,python_targets_python2_7(-)?,-python_single_target_python2_6(-),-python_single_target_python2_7(-)]" have been masked.
!!! One of the following masked packages is required to complete your request:

- dev-python/pygobject-3.4.2-r1000::gentoo (masked by: )
- dev-python/pygobject-3.2.2-r1000::gentoo (masked by: )

(dependency required by ".../..." [ebuild])

# After unmasking all versions to no avail (it is being masked by nothing after
# all. '(masked by: )' was copied directly from the error message )
# I upgraded portage from portage-2.3.5-r5 to portage-2.3.5-r6. And Wala. Fixed.
# Not sure if it was just a bug in portage or if an external process called while
# portage updates fixed it, but its all good now.
# To see what version of portage you have, and all availible versions. type
equery list -po portage
# To upgrade portage, type
emerge -1 portage
# (note you shouldn't have any probems while upgrading. if it refuses to upgrade with
# the same error, report it). Now you should be able to continue emerging whatever
# you were trying to emerge previousle.my (eg. below )
emerge -NavDu --with-bdeps\=y --keep-going @world

Last edited by mmix (2013-02-16 01:44:50)

Offline

Board footer

Powered by FluxBB