You are not logged in.

#1 2013-02-13 01:57:46

Gumbo
New member
Registered: 2013-02-13
Posts: 3

Mouse not working in Virtualbox install

I spent the last few days installing Funtoo in a virtualbox, when I installed xorg and xfce ontop of it, my mouse cursor would not move. The mouse I use is a roccat savu gaming mouse. Any ideas?

Offline

#2 2013-02-13 02:11:10

Gumbo
New member
Registered: 2013-02-13
Posts: 3

Re: Mouse not working in Virtualbox install

Got it working. This is how I did it.

emerge xf86-input-evdev

Offline

#3 2013-02-13 05:49:35

jcadam
Member
Registered: 2011-05-28
Posts: 27

Re: Mouse not working in Virtualbox install

This is actually ticky. Every time when xserver or any package depends on input device drivers got updated, it happends for sure. You will lose input due to incompatible driver versions.

Is there a way to ensure drivers got updated too in these cases?

Offline

#4 2013-02-13 05:54:43

angry_vincent
Staff
From: Ukraine
Registered: 2010-10-07
Posts: 687

Re: Mouse not working in Virtualbox install

You have to rebuild x11-drivers after each X update.

Offline

#5 2013-02-13 05:57:40

jcadam
Member
Registered: 2011-05-28
Posts: 27

Re: Mouse not working in Virtualbox install

angry_vincent wrote:

You have to rebuild x11-drivers after each X update.

It is true. However, is there no better way for doing this? Something like updating installed drivers whenever xserver updated?

Offline

#6 2013-02-13 05:59:30

angry_vincent
Staff
From: Ukraine
Registered: 2010-10-07
Posts: 687

Re: Mouse not working in Virtualbox install

there is a postinstall message about rebuilding x11-drivers.

Offline

Board footer

Powered by FluxBB