You are not logged in.

#1 2013-02-12 18:00:11

stifler83
Member
Registered: 2011-01-27
Posts: 56

Strange problem with portage

Hi guys, I have this problem, when I run:

emerge -uNDav @world

this is the output:

These are the packages that would be merged, in order:

Calculating dependencies | * ERROR: app-emulation/qemu-1.2.2-r3 failed (depend phase):
 *   Invalid syntax of PYTHON_DEPEND: Unrecognized minimal version '2.4'
 * 
 * Call stack:
 *              ebuild.sh, line 551:  Called source '/usr/portage/app-emulation/qemu/qemu-1.2.2-r3.ebuild'
 *   qemu-1.2.2-r3.ebuild, line  11:  Called inherit 'eutils' 'flag-o-matic' 'linux-info' 'toolchain-funcs' 'multilib' 'python' 'user' 'udev'
 *              ebuild.sh, line 286:  Called __qa_source '/usr/portage/eclass/python.eclass'
 *              ebuild.sh, line  80:  Called source '/usr/portage/eclass/python.eclass'
 *          python.eclass, line 579:  Called _python_parse_dependencies_in_old_EAPIs 'PYTHON_DEPEND' 'DEPEND RDEPEND'
 *          python.eclass, line 372:  Called _python_parse_versions_range '2:2.4' 'PYTHON_DEPEND' '_PYTHON_ATOMS'
 *          python.eclass, line 293:  Called die
 * The specific snippet of code:
 *                              die "Invalid syntax of ${input_variable}: Unrecognized minimal version '${minimal_version}'"
 * 
 * If you need support, post the output of `emerge --info '=app-emulation/qemu-1.2.2-r3'`,
 * the complete build log and the output of `emerge -pqv '=app-emulation/qemu-1.2.2-r3'`.
 * Working directory: '/home/mauro'
 * S: '/var/tmp/portage/app-emulation/qemu-1.2.2-r3/work/qemu-1.2.2'
... done!
[ebuild     U  ] dev-libs/openssl-1.0.1d-r1 [1.0.1c] USE="(sse2) zlib -bindist -gmp -kerberos -rfc3779 -static-libs {-test} -vanilla" 4,356 kB

Anyone can help me?

Last edited by stifler83 (2013-02-12 18:01:10)

Offline

#2 2013-02-12 19:27:05

overkill
Member
Registered: 2011-09-13
Posts: 243

Re: Strange problem with portage

Really?  Did you not see the 2 previous posts to yours?

Just answer yes at the yes/no prompt.  The qemu bug has already been reported to funtoo:

http://bugs.funtoo.org/browse/FL-409

Offline

Board footer

Powered by FluxBB