You are not logged in.

#1 2013-01-21 21:01:28

leprosys
Member
From: El Salvador
Registered: 2010-10-07
Posts: 54

ZFS on Funtoo

I tried ZFS, following the wiki guide http://www.funtoo.org/wiki/ZFS_Install_Guide
I found some problems:

With System Rescue CD, I can't continue after create the swap, the message "may not be immediately available" appears so /dev/zvol/rpool/swap not exist. I had to use Gentoo LiveDVD End Of World Edition instead.

With the initramfs of Bliss doesn't create the mount point NEW_ROOT="/mnt/root"
In the file "files/init" I added: mkdir -p "${NEW_ROOT}" <= this solved the problem

With genkernel doesn't work the files are missing like zpool <= so can't do anything
Dracut and boot-update has no support for ZFS.

My current problem is with pulseaudio (Yep ZFS on desktop):
In the boot pulseaudio create the config files in some directories one of these is /root, so I think when udev daemon run creates /root then ZFS failed mount /root, you need delete /root and run: zfs mount tank/HOME/root

For grub.cfg:

set timeout=3

menuentry "Funtoo Linux - bzImage" {
  insmod part_gpt
  insmod ext2
  set root=(hd0,1)
  search --no-floppy --fs-uuid --set 35906890-e649-48b6-a8f4-3d3c5da3f9f8
  linux /vmlinuz-3.7.3-gentoo root=tank/ROOT/funtoo dozfs=force video=uvesafb:1440x900-32,mtrr:3,ywrap
  initrd /initrd-3.7.3-gentoo.img
  set gfxpayload=keep
}
set default=0

And that's all for now

Last edited by leprosys (2013-01-21 23:29:19)

Offline

#2 2013-02-05 03:38:06

fearedbliss
Core Team Member
Registered: 2012-05-07
Posts: 12

Re: ZFS on Funtoo

Hey Leprosys,

All of your problems should now be fixed with the latest version of initramfs 1.6.5. You should definitely be able to get your system, swap, and initramfs working now. Use the 1.6.5 of my initramfs and 0.6.0_rc14 of zfs.

Offline

Board footer

Powered by FluxBB