You are not logged in.

#1 2012-12-20 19:10:06

syn418
Member
Registered: 2012-12-17
Posts: 11

[solved] rxvt-unicode square colored characters

I have installed rxvt-unicode terminal. The prompt or any colored character in the directories are rendered as squares, all none colored characters are fine. I have no idea how to start troubleshooting this problem.

Last edited by syn418 (2012-12-30 21:49:24)

Offline

#2 2012-12-23 19:45:22

dodo3773
Member
Registered: 2012-09-19
Posts: 14

Re: [solved] rxvt-unicode square colored characters

Is rxvt-unicode built with USE="256-color"? What are your build options for the package? Maybe that would help get to the bottom of this.

Offline

#3 2012-12-30 21:00:19

syn418
Member
Registered: 2012-12-17
Posts: 11

Re: [solved] rxvt-unicode square colored characters

Enviroment:
x86_64 (Core2) / Current / Desktop Profile

Default use flags:
x11-terms/rxvt-unicode-9.15-r1  USE="focused-urgency font-styles mousewheel perl vanilla -256-color -afterimage -alt-font-width -blink -buffer-on-clear -fading-colors -iso14755 -pixbuf -secondary-wheel -startup-notification -unicode3 -wcwidth -xft" 0 kB

Offline

#4 2012-12-30 21:07:23

dodo3773
Member
Registered: 2012-09-19
Posts: 14

Re: [solved] rxvt-unicode square colored characters

syn418 wrote:

Enviroment:
x86_64 (Core2) / Current / Desktop Profile

Default use flags:
x11-terms/rxvt-unicode-9.15-r1  USE="focused-urgency font-styles mousewheel perl vanilla -256-color -afterimage -alt-font-width -blink -buffer-on-clear -fading-colors -iso14755 -pixbuf -secondary-wheel -startup-notification -unicode3 -wcwidth -xft" 0 kB

Try changing USE="256-color xft " for that package in package.use and re-emerge that package. After that set up a monospace font in .Xresources to test. Not sure what to tell you other than that.

Edit: Maybe check your locale too to make sure that's not the issue.

Last edited by dodo3773 (2012-12-30 21:09:14)

Offline

#5 2012-12-30 21:49:00

syn418
Member
Registered: 2012-12-17
Posts: 11

Re: [solved] rxvt-unicode square colored characters

The xft use flag solved the problem
Thank you dodo3773

Offline

#6 2012-12-30 21:50:39

dodo3773
Member
Registered: 2012-09-19
Posts: 14

Re: [solved] rxvt-unicode square colored characters

syn418 wrote:

The xft use flag solved the problem
Thank you dodo3773

You're welcome.

Offline

Board footer

Powered by FluxBB