You are not logged in.

#1 2012-12-03 16:52:52

Judge
Staff
From: Germany, NRW, Heiligenhaus
Registered: 2011-07-03
Posts: 283

[Solved] Trying to understand a mask

Hi everyone!

I just stumbled upon a mask, which I do not understand and hope someone can explain this to me.
I have www-apps/mediawiki-1.20.1 installed, which seems to somehow nail my dev-lang/php to 5.3.15 . dev-lang/php-5.3.19 is available, but I get the following when I try to update it:

tango011 / # emerge -uvaND dev-lang/php

...

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-lang/php-5.3.15:5.3  USE="apache2 bcmath berkdb bzip2 calendar cli crypt ctype curl exif fileinfo filter ftp gd gdbm hash iconv imap inifile intl ipv6 json mhash mysql mysqli nls pdo phar posix postgres* readline session simplexml snmp soap sockets spell sqlite sqlite3 ssl suhosin tidy tokenizer truetype unicode wddx xml xmlreader xmlrpc xmlwriter xsl zip zlib -cdb -cgi -cjk -curlwrappers -debug -doc -embed -enchant -firebird -flatfile -fpm (-frontbase) -gmp -iodbc -kerberos (-kolab) -ldap -ldap-sasl -libedit -mssql -mysqlnd -oci8-instant-client -odbc -pcntl -pic -qdbm -recode -sharedmem (-sybase-ct) -sysvipc -threads -xpm" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

WARNING: One or more updates have been skipped due to a dependency conflict:

dev-lang/php:5.3

  (dev-lang/php-5.3.19::gentoo, ebuild scheduled for merge) conflicts with
    >=dev-lang/php-5.3.2[sqlite3,pdo] required by (www-apps/mediawiki-1.20.1::gentoo, installed)

When I take a look into the mediawiki-ebuild, I find this:

RDEPEND=">=dev-lang/php-5.3.2[mysql?,postgres?,session,xml,xmlreader]
    imagemagick? ( || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] ) )
    !imagemagick? ( dev-lang/php[gd] )
    sqlite? (
        dev-db/sqlite:3[fts3]
        >=dev-lang/php-5.3.2[sqlite3,pdo]
    )
    virtual/httpd-php"

Which, as far as I understand, for the PHP version only tells that dev-lang/php greater or equal to 5.3.2 is needed by it. I do not get why this makes PHP stick to 5.3.15 . When mediawiki is removed, portage updates dev-lang/php to 5.3.19 . When mediawiki-1.20.1  is remerged afterwards, it forces dev-lang/php back to 5.3.15 . Has anybody a clue why this is happening?

Last edited by Judge (2012-12-04 16:42:59)

Offline

#2 2012-12-04 15:37:51

angry_vincent
Staff
From: Ukraine
Registered: 2010-10-07
Posts: 687

Re: [Solved] Trying to understand a mask

https://bugs.gentoo.org/show_bug.cgi?id=444484 yes, dependency looks screwed

Offline

#3 2012-12-04 16:39:29

Judge
Staff
From: Germany, NRW, Heiligenhaus
Registered: 2011-07-03
Posts: 283

Re: [Solved] Trying to understand a mask

Ah, great! That sqlite - Flag is the bad dude ... that's what I wanted to understand! Thank you! smile

Offline

Board footer

Powered by FluxBB