You are not logged in.

#1 2012-12-02 20:24:19

overkill
Member
Registered: 2011-09-13
Posts: 243

gst-plugins-bad-0.10.22 fails to reinstall

...
/work/gst-plugins-bad-0.10.22/tools'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/var/tmp/portage/media-libs/gst-plugins-bad-0.10.22/work/gst-plugins-bad-0.10.22/tools'
make[2]: Entering directory `/var/tmp/portage/media-libs/gst-plugins-bad-0.10.22/work/gst-plugins-bad-0.10.22'
make[2]: Leaving directory `/var/tmp/portage/media-libs/gst-plugins-bad-0.10.22/work/gst-plugins-bad-0.10.22'
make[1]: Leaving directory `/var/tmp/portage/media-libs/gst-plugins-bad-0.10.22/work/gst-plugins-bad-0.10.22'
>>> Source compiled.
>>> Test phase [not enabled]: media-libs/gst-plugins-bad-0.10.22

>>> Install gst-plugins-bad-0.10.22 into /var/tmp/portage/media-libs/gst-plugins-bad-0.10.22/image/ category media-libs
 * ERROR: media-libs/gst-plugins-bad-0.10.22 failed (install phase):
 *   __eapi2_src_install is not supported
 * 
 * Call stack:
 *            ebuild.sh, line   93:  Called src_install
 *          environment, line 2690:  Called default
 *   phase-functions.sh, line  779:  Called __eapi2_src_install
 *   phase-functions.sh, line  773:  Called die
 * The specific snippet of code:
 *   				__eapi2_src_install   () { die "$FUNCNAME is not supported" ; }
...

Looks like an ebuild issue?  with "__eapi2_src_install is not supported"

Offline

#2 2012-12-03 03:47:40

angry_vincent
Staff
From: Ukraine
Registered: 2010-10-07
Posts: 687

Re: gst-plugins-bad-0.10.22 fails to reinstall

does it work with MAKEOPTS="-j1"?
ok, reducing to EAPI=2 should fix it, probably will hit the tree next sync.

Offline

#3 2012-12-04 00:38:42

overkill
Member
Registered: 2011-09-13
Posts: 243

Re: gst-plugins-bad-0.10.22 fails to reinstall

Didn't get a chance to test it.  --sync 'd up and upgraded to 0.10.23.  Compiled and installed fine.

Offline

Board footer

Powered by FluxBB