You are not logged in.

#1 2012-11-25 11:07:04

Kr1
New member
Registered: 2012-11-25
Posts: 2

boot-update cannot find a valid / entry in /etc/fstab

Hi, got a problem with boot-update
I'm trying to install funtoo on fully encrypted disk.

having trouble with the installation instructions especially with the instructions fir the intramfs and the bootloader.

I can boot from a usb drive and decrypt and chroot in (im in the env now :-) .. but can boot normally...

I have found some good advise at http://preney.ca/paul/archives/389

And have got to the end, but boot-update fails.. (to be honest I don't know how it works and why we need yet more confusion on top of grub2 :-)

here is the error message (followed by /etc/boot.conf anf /etc/fstab  please any help is appreciated  :--


sysresccd linux # boot-update

boot-update 1.6.7 /
Copyright 2009-2012 Funtoo Technologies

[use option "-l" for license info, "-h" for help]

* Generating config for grub...

* ERROR : (rootfstype=auto) - cannot find a valid / entry in /etc/fstab.
* ERROR : (rootfstype=auto) - cannot find a valid / entry in /etc/fstab.
* ERROR : No matching kernels or boot entries found in /etc/boot.conf.
* Did not complete successfully.



######this is my /etc/boot.conf ############
boot {
        generate grub
        default "Funtoo Linux genkernel (passphrase boot)"
        timeout 3
}


"Funtoo Linux genkernel (passphrase boot)" {
        kernel kernel[-v]
        initrd initramfs[-v]
        params += root=/dev/ram0 crypt_root=UUID=cf86d437-54dd-4413-a8aa-8389a1c30de8 real_root=/dev/mapper/lvg-root rootfstype=ext4 key_timeout=0 res
}
#####################


#####the following is my /etc/fstab ###########

# use blkid to determin uuid's we need these because usin lvm we don't know the names untill mapped
# /dev/mapper/lvg-root ROOT_NAME
UUID=a6959738-52dc-4fbf-8880-4008f31d7779    /        ext4 discard,noatime,nodiratime,errors=rmount-ro    0 1

#/dev/sda1 = BOOT_DEV
UUID=fc3cc2ac-35e7-4f28-97bc-dfc8ba59fd20    /boot        ext4 discard,noauto,noatime,nodiratime,errors=remount-ro    1 2

# /dev/mapper/lvg-swap
UUID=1f8490b1-1ed5-4e32-a45c-b354f74ffc7b    none        swap sw        0 0

#/dev/mapper/lvg-rest rest of disk
UUID=247ecfdb-80a0-4929-bbf9-073d4bb3341d    /rest        ext4 discard,noatime,nodiratime,errors=rmount-ro    0 2

none            /dev/shm    tmpfs nodev,nosuid,noexec 0 0
none            /tmp            tmpfs nodev,nosuid,noexec,size=256M 0 0
proc            /proc        proc    defaults    0 0

/rest/home        /home        none        rw,rbind    0 0
/rest/opt        /opt        none        rw,rbind    0 0


#/dev/cdrom        /mnt/cdrom    auto        noauto,ro    0 0
#none            ${VARTMP_MOUNT}    tmpfs        defaults,size=256M    0 0
###############################

Offline

#2 2012-11-26 21:45:53

kaorihinata
Member
Registered: 2011-06-13
Posts: 34

Re: boot-update cannot find a valid / entry in /etc/fstab

Ah, I believe the problem comes from the fact that you've specified a "params += [VALUE]" line without first specifying a "params [VALUE]" line to set the initial value. As a result, you're appending parameters to a default set of parameters, which includes an automatic search of /etc/fstab for the root filesystem type (rootfstype=auto). The reason it failed was ultimately because boot-update doesn't support UUID or LABEL when searching /etc/fstab for the root filesystem.

Anyway, to solve your problem, try removing the "+=" from your params line so it reads:

params root=/dev/ram0 crypt_root=UUID=cf86d437-54dd-4413-a8aa-8389a1c30de8 real_root=/dev/mapper/lvg-root rootfstype=ext4 key_timeout=0 res

For readability sake, you might also want to consider splitting up your parameters so that they're easier to read through. For example:

params foo
params += bar
params += baz

Just make sure that you use "params [VALUE]" first to override the default settings if you aren't going to use them. Of course, any corrections to the above are welcome.

Offline

#3 2012-11-28 13:00:39

Kr1
New member
Registered: 2012-11-25
Posts: 2

Re: boot-update cannot find a valid / entry in /etc/fstab

great thanks fro that it worked :-) I can now boot.

The only issue is that only  my filesystem mounted read only... it turns out I configured fstab wrong.

ext4 filesystem mount command does not recognise the "errors=remount-ro" option... remove that and it all boots nicely :-)

Thanks for all the help

Last edited by Kr1 (2012-11-28 13:37:18)

Offline

#4 2012-11-28 14:12:50

san2ban
Member
From: Bangalore, India
Registered: 2012-03-20
Posts: 146

Re: boot-update cannot find a valid / entry in /etc/fstab

If your issue is resolved, pl. mark this thread as 'solved'

Offline

#5 2012-11-28 14:26:06

kaorihinata
Member
Registered: 2011-06-13
Posts: 34

Re: boot-update cannot find a valid / entry in /etc/fstab

No problem, Kr1.

Offline

Board footer

Powered by FluxBB