You are not logged in.

#1 2012-11-13 23:55:31

syl
Member
From: Au bord de l'eau à Groland
Registered: 2012-03-30
Posts: 17

[SOLVED] tried to move experimental, portage broken

Solved :

localhost portage # more /etc/portage/make.profile/parent 
gentoo:funtoo/1.0/linux-gnu/arch/x86-64bit
gentoo:funtoo/1.0/linux-gnu/build/current
gentoo:funtoo/1.0/linux-gnu/flavor/desktop
gentoo:funtoo/1.0/linux-gnu/mix-ins/kde
list <------- comment that

so add a # behind that buggy line

# list <------- comment that

Hi !

I have little problems these days with internet provider (I moved in semi-desert) so i did upgrade recently from a while, and it seems my system have some problems regarding udev (it wants udev-171, i really dont understand, because i know gentoo and funtoo block it), but more important i tried to "eselect profile replace 3 4" (so i tried to move experimental, because at some point i believed it could handle things better regarding another problem, was... just bulding that udev-171) so now emerge says ... "NO you cant !!" -seems related to profile, things like that- (even rolling back dont solve it, and even copying bin and pym from github to local portage) !

What to do next to make it smile ?
I thought the wiki page is outdated (talks about 2011 profile), but maybe i get wrong ?


<OFF TOPIC>
Please, everytime that something go bad state in my Linux experience, i switch. I tried Debian (4 years, left for boredom), Gentoo (6 years, left because of illogical package maintain, i understand now that was not the fault of gentoo, but because of upstream), Windows XP, 7 and even 8, that's stupid but i want a Linux system that builds in my hands (like gentoo) and run fine (like Debian).
I'm serious.
Just my personal opinion, but i think part of Linux scene think moving from servers to desktop (mainly because they're not sysops, and also because they think that automount is the summit of Kilimanjaro -hey kde do that without systemd, and kde do a lot of fancy things also, i dont need systemd to replace those features-), and that's a bad move, because an init system that wants desktop related stuff... Windows ? You need to get serious to work in IT !! Or go and fork that shit to a "Linux-Desktop", but please people behind that stupid idea of systemd, stop fussing around saying something can work everywhere, everytime, in every universe... even microsoft understand that an O/S can't be identically designed for different use !

Tell me, it's not the time to go back to C64 ?? smile

</OFF TOPIC>

Last edited by syl (2012-11-14 19:35:46)

Offline

#2 2012-11-17 19:24:34

syl
Member
From: Au bord de l'eau à Groland
Registered: 2012-03-30
Posts: 17

Re: [SOLVED] tried to move experimental, portage broken

haa feel better now, dunno where i was neutral

localhost ~ # emerge -uDNp @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sys-fs/udev-171-r7  USE="(-extras*)"
[ebuild   R    ] x11-libs/libdrm-2.4.40  USE="libkms*"
[ebuild  N     ] sys-apps/module-init-tools-3.16-r1  USE="-static"
[uninstall     ] sys-apps/kmod-11-r1
[blocks b      ] sys-apps/module-init-tools ("sys-apps/module-init-tools" is blocking sys-apps/kmod-11-r1)
[ebuild  N     ] media-libs/glu-9.0.0  USE="(-multilib) -static-libs"
[ebuild     U  ] media-libs/mesa-9.0 [8.0.4-r1] USE="xorg%* -r600-llvm-compiler%" VIDEO_CARDS="-radeonsi%"
[blocks b      ] <media-libs/mesa-9 ("<media-libs/mesa-9" is blocking media-libs/glu-9.0.0)
[ebuild     U  ] x11-base/xorg-server-1.13.0-r1 [1.12.4]

Offline

Board footer

Powered by FluxBB