You are not logged in.

#1 2012-10-10 02:35:48

melo
New member
From: Shah Alam City, Malaysia
Registered: 2012-10-05
Posts: 6

[SOLVED]kernel module "smsc47m1.ko" failed to start

Hi guys,

I tried to load "smsc47m1.ko" kernel module and getting this error. I'm running debian-sources 3.2.29-1 binary compiled by genkernel (guide from funtoo.org installation guide)

# modprobe smsc47m1
FATAL: Error inserting smsc47m1 (/lib/modules/3.2.29-1/kernel/drivers/hwmon/smsc47m1.ko): Device or resource busy

I also altered my "boot.conf" to have the params and executed "boot-update" but still the module won't load.

boot {
        generate grub
        default "Funtoo Linux genkernel"
        timeout 3
}

"Funtoo Linux" {
        kernel bzImage[-v]
}

"Funtoo Linux genkernel" {
        kernel kernel[-v]
        initrd initramfs[-v]
        params += real_root=auto
        params += GRUB_CMDLINE_LINUX_DEFAULT="acpi_enforce_resources=lax"
        # params += acpi_enforce_resources=lax
}

Any help guys?

Thanks.

Last edited by melo (2012-11-05 04:39:24)

Offline

#2 2012-10-10 02:57:34

melo
New member
From: Shah Alam City, Malaysia
Registered: 2012-10-05
Posts: 6

Re: [SOLVED]kernel module "smsc47m1.ko" failed to start

opss..i posted it at the wrong section..should be at Tech Support/Troubleshooting..sorry

Offline

#3 2012-10-10 03:44:34

angry_vincent
Staff
From: Ukraine
Registered: 2010-10-07
Posts: 687

Re: [SOLVED]kernel module "smsc47m1.ko" failed to start

Offline

#4 2012-10-10 03:53:26

melo
New member
From: Shah Alam City, Malaysia
Registered: 2012-10-05
Posts: 6

Re: [SOLVED]kernel module "smsc47m1.ko" failed to start

thx vincent..after reading the explanation in those links above..i've decided not to enforce this module since it is not suggested by lm-sensors..there must be a reason for it though..

Offline

Board footer

Powered by FluxBB