Jump to content

Photo

dev-cpp/glibmm-2.44 & dev-cpp/gtkmm-2.24.4-r2

- - - - - portage ebuild dev-cpp build failure glibmm gtkmm

Best Answer cardinal , 23 November 2015 - 01:49 AM

Current pure64 system.

rj@funtoo ~# emerge -1av gtkmm 

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/libsigc++-2.6.2:2::gentoo  USE="-doc -static-libs {-test}" 0 KiB
[ebuild  N     ] dev-cpp/glibmm-2.44.0:2::gentoo  USE="-debug -doc -examples {-test}" 0 KiB
[ebuild  N     ] dev-cpp/cairomm-1.12.0::gentoo  USE="svg -doc" 0 KiB
[ebuild  N     ] dev-cpp/atkmm-2.22.7-r1::gentoo  USE="-doc" 0 KiB
[ebuild  N     ] dev-cpp/pangomm-2.36.0:1.4::gentoo  USE="-doc" 0 KiB
[ebuild  N     ] dev-cpp/gtkmm-3.16.0:3.0::gentoo  USE="X (-aqua) -doc -examples {-test} -wayland" 0 KiB

Total: 6 packages (6 new), Size of downloads: 0 KiB

First build failure is dev-cpp/glibmm-2.44.0.
First error in /var/log/portage/dev-cpp:glibmm-2.44.0:20151122-063358.log
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/include/g++-v4.9/bits/c++0x_warning.h:32:2: error: #error
This file requires compiler and library support for the ISO C++ 2011 standard.
This support is currently experimental, and must be enabled with the -std=c++11 or -std=gnu++11 compiler options.
#error This file requires compiler and library support for the \
Three more packages(atkmm,pangomm,gtkmm)in group failed with same error.
I add "-std=c++11" to compile flags for failed packages using package environment configuration.
Create /etc/portage/package.env file if it doesn't exist.
Add this text to /etc/portage/package.env
dev-cpp/glibmm -std=c++11.conf
dev-cpp/atkmm -std=c++11.conf
dev-cpp/pangomm -std=c++11.conf
dev-cpp/gtkmm -std=c++11.conf              
Create folder path if it doesn't exist.
mkdir -p /etc/portage/env
nano /etc/portage/env/-std=c++11.conf
Add this text to -std=c++11.conf
CFLAGS="${CFLAGS} -std=c++11"
CXXFLAGS="${CXXFLAGS} -std=c++11"
Eventually all six packages merged.
 
Reference:
Gentoo's Bugzilla – Bug 565342 dev-cpp/gtkmm-2.24.4-r2 - -std=c++11 required?
How do I configure environment variable settings that apply only to specific packages? Go to the full post »


2 replies to this topic

#1
jmmc

jmmc

    Member

  • Members
  • PipPip
  • 17 posts

Hi -
 

Is anyone having issues with these two ebuilds in the last two or three days?

After recent update of @world, I am left with only two these packages which fail to build. Thought I would quick post here to see it anyone else had noticed issues with these two packages recently. Checking at bugs.funtoo.org, a search shows no recent trouble with these.
 

Best Regards



#2
cardinal

cardinal

    Advanced Member

  • Members
  • PipPipPip
  • 223 posts
✓  Best Answer
Current pure64 system.
rj@funtoo ~# emerge -1av gtkmm 

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/libsigc++-2.6.2:2::gentoo  USE="-doc -static-libs {-test}" 0 KiB
[ebuild  N     ] dev-cpp/glibmm-2.44.0:2::gentoo  USE="-debug -doc -examples {-test}" 0 KiB
[ebuild  N     ] dev-cpp/cairomm-1.12.0::gentoo  USE="svg -doc" 0 KiB
[ebuild  N     ] dev-cpp/atkmm-2.22.7-r1::gentoo  USE="-doc" 0 KiB
[ebuild  N     ] dev-cpp/pangomm-2.36.0:1.4::gentoo  USE="-doc" 0 KiB
[ebuild  N     ] dev-cpp/gtkmm-3.16.0:3.0::gentoo  USE="X (-aqua) -doc -examples {-test} -wayland" 0 KiB

Total: 6 packages (6 new), Size of downloads: 0 KiB

First build failure is dev-cpp/glibmm-2.44.0.
First error in /var/log/portage/dev-cpp:glibmm-2.44.0:20151122-063358.log
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/include/g++-v4.9/bits/c++0x_warning.h:32:2: error: #error
This file requires compiler and library support for the ISO C++ 2011 standard.
This support is currently experimental, and must be enabled with the -std=c++11 or -std=gnu++11 compiler options.
#error This file requires compiler and library support for the \
Three more packages(atkmm,pangomm,gtkmm)in group failed with same error.
I add "-std=c++11" to compile flags for failed packages using package environment configuration.
Create /etc/portage/package.env file if it doesn't exist.
Add this text to /etc/portage/package.env
dev-cpp/glibmm -std=c++11.conf
dev-cpp/atkmm -std=c++11.conf
dev-cpp/pangomm -std=c++11.conf
dev-cpp/gtkmm -std=c++11.conf              
Create folder path if it doesn't exist.
mkdir -p /etc/portage/env
nano /etc/portage/env/-std=c++11.conf
Add this text to -std=c++11.conf
CFLAGS="${CFLAGS} -std=c++11"
CXXFLAGS="${CXXFLAGS} -std=c++11"
Eventually all six packages merged.
 
Reference:
Gentoo's Bugzilla – Bug 565342 dev-cpp/gtkmm-2.24.4-r2 - -std=c++11 required?
How do I configure environment variable settings that apply only to specific packages?

#3
jmmc

jmmc

    Member

  • Members
  • PipPip
  • 17 posts

Many thanks cardinal!

All is well. Creating/editing the package-specific env vars enabled the packages to compile without error.

 

Sláinte!





Reply to this topic



  



Also tagged with one or more of these keywords: portage, ebuild, dev-cpp, build failure, glibmm, gtkmm

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users