Jump to content

Photo

x11-drivers/nvidia-drivers-355.11-r2 wont compile

nvidia kernel

2 replies to this topic

#1
ainsley31415926

ainsley31415926

    Newbie

  • Members
  • Pip
  • 9 posts

 x11-drivers/nvidia-drivers-355.11-r2 wont compile with kernel linux-4.3.0-gentoo

 

/var/tmp/portage/x11-drivers/nvidia-drivers-355.11-r2/work/kernel/nvidia/nv-procfs.c: In function ‘nv_procfs_read_registry’:
 

/var/tmp/portage/x11-drivers/nvidia-drivers-355.11-r2/work/kernel/nvidia/nv-procfs.c:363:5: error: void value not ignored as it ought to be
     return seq_printf(s, "Binary: \"%s\"\n", registry_keys);

 

 



#2
cardinal

cardinal

    Advanced Member

  • Members
  • PipPipPip
  • 227 posts

 x11-drivers/nvidia-drivers-355.11-r2 says kernel-4.3 or greater are not supported yet.
Gentoo supports kernels which are supported by NVIDIA"
"which are limited to the following kernels:"
"<sys-kernel/gentoo-sources-4.3"
"<sys-kernel/vanilla-sources-4.3"

 

Try epatch_user with this patch: https://devtalk.nvid...c1-build-error/



#3
fsociety

fsociety

    Newbie

  • Members
  • Pip
  • 3 posts

Unmask 358.16-r1 and you won't have an issue.  They maybe beta but its better than using that fix I personally think.

 

Just add

=x11-drivers/nvidia-drivers-358.16-r1

to your /etc/portage/package.unmask file and emerge it.

 





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users