Jump to content

Photo

Xorg Segmentation Fault for Kernels 4.x

- - - - -

Best Answer mahalay , 12 August 2015 - 08:33 AM

Solution:
 
Add this line in /etc/portage/package.accept_keywords
=x11-drivers/xf86-video-intel-2.99.917-r2 ~amd64
 
Then...
emerge x11-drivers/xf86-video-intel
 
Who are affected:
  • those using amd64 arch (stable)
  • using 4.x kernel (observed in gentoo-sources and tuxonice-sources)
  • using xf86-video-intel-2.99.917 (r2 fixes the issue)
Go to the full post »


3 replies to this topic

#1
mahalay

mahalay

    Newbie

  • Members
  • Pip
  • 5 posts

I'm out of ideas how to fix the problem, please my logs, I hope somebody can decode what could possibly be the underlying problem. 

http://pastebin.com/DZq6jxXS 

I'm not sure if I missed any kernel config, tried rebuilding glibc because a line tells me it segfaults there. Rebuilt xf86-video-intel and nvidia-drivers - still no luck. Re-emerge x11-drivers/* that I use, xorg-server, etc... still no luck. 

Tried gentoo-sources too, still no luck. Hope someone can help. 

I am stuck with 3.19 (debian-sources), however, I can't make my hdmi and displayports to work. xrandr -q does not report anything related to HDMI and DPs. 

Thanks in advance. 

*** 

My Machine: 

MSI GT60 2QD 
Intel Corporation 4th Gen Core Processor Integrated Graphics Controller 
NVIDIA Corporation GM204M [GeForce GTX 970M] 
Intel® Core™ i7-4710MQ CPU @ 2.50GHz

 

NOTE: I've also posted this in https://forums.gento...highlight-.html


  • uotobirofabo, iqemiyuxidal, iepuziqezuwa and 7 others like this

#2
jorgicio

jorgicio

    Advanced Member

  • Members
  • PipPipPip
  • 58 posts
  • LocationViƱa del Mar

Are you using current? Maybe check this http://forums.funtoo...a-works-at-uxa/



#3
mahalay

mahalay

    Newbie

  • Members
  • Pip
  • 5 posts

Hey jorgicio,

 

Thanks man! That's the option I haven't tried yet, will try it later. I've also uncovered two most likely related bugs:

 

https://bugs.gentoo....g.cgi?id=552124

https://bugs.gentoo....g.cgi?id=556264

 

As pointed out by cool dudes at Gentoo: https://forums.gento...topic-p-7795772

 

I'll post my findings later (if time permits)



#4
mahalay

mahalay

    Newbie

  • Members
  • Pip
  • 5 posts
✓  Best Answer
Solution:
 
Add this line in /etc/portage/package.accept_keywords
=x11-drivers/xf86-video-intel-2.99.917-r2 ~amd64
 
Then...
emerge x11-drivers/xf86-video-intel
 
Who are affected:
  • those using amd64 arch (stable)
  • using 4.x kernel (observed in gentoo-sources and tuxonice-sources)
  • using xf86-video-intel-2.99.917 (r2 fixes the issue)




Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users