Jump to content

Photo

Pulsaudo fails to compile

- - - - - portage sound pulseaudio alsa gnome

Best Answer j-g- , 18 July 2015 - 02:15 AM

I oneshotted speex, and the compile worked. I was given a lot of errors, but the compile seemed to work. Can someone tell me if these are bad?

 

 

Spoiler

 

There were many similar errors, and the compile took a very long time.

Did you re-run  the ebuild command 2 times from inside /var/tmp/portage/... the directories created get remove everytime you try to do a new build either using emerge  or ebuild ... clean, I have had similar errors when I forgot to cd out of the autogenerated directories.

Now that you have identified that the failure is in speex, report a bug so the dependecy get's added to the ebuild so this error doesn't happen to other people.

Since you emerged it with one-shot you shouldn't have any problems once it gets fixed. you can try from your home dir, to check the errors are because of what I tell you before.
$ sudo emerge --oneshot pulseaudio

Go to the full post »


13 replies to this topic

#1
keitho2000

keitho2000

    Member

  • Members
  • PipPip
  • 15 posts

I have been struggling to install gnome for a while now. There was a recent bugfix that was fixed a problem with the spidermonkey installation, but now I'm running into problems with pulseaudio. Whenever I try to emerge it, I get the following errors just after compilation starts:

 

Spoiler

 

Here is the output of the emerge --info '=blah blah blah':

Spoiler

 

 



#2
Sandro

Sandro

    Advanced Member

  • Members
  • PipPipPip
  • 334 posts
  • LocationSaronno, Via IV Novembre, 23 21047 Italy

What tells to You

# emerge -DNu world --with-bdeps=y -pv

and

euse -I pulseaudio

?

 

and

emerge -DNu1 pulseaudio -pv

?

 

 

Now I'm trying to install also Gnome (i use KDE); and i've also xfce4.

_______________________

 

another idea that I have is to compile withoud pulseaudio; once terminated, euse -E pulseaudio to set it globally then emerge -DNu world --with-bdeps=y.



#3
keitho2000

keitho2000

    Member

  • Members
  • PipPip
  • 15 posts

I got the same errors after running those commands. :( When I try to compile without pulseaudio support, portage tells me that gnome requires the pulseaudio USE flag. If you're trying to install gnome too, there was a bugfix last night that fixed some problems with the installation of spidermonkey (https://bugs.funtoo.org/browse/FL-2642).



#4
Sandro

Sandro

    Advanced Member

  • Members
  • PipPipPip
  • 334 posts
  • LocationSaronno, Via IV Novembre, 23 21047 Italy

I'm installing gnome; cause we can see if this problem is also for my machine ..... :)

but i start in a situation where pulseaudio is enabled globally :| ..... I'll be glade to give an hand .....

 

But also "emerge -DNu1 pulseaudio" give you error ?

 

This is the mine:

 

[ebuild   R    ] media-sound/pulseaudio-5.99.3-r1  USE="X alsa alsa-plugin asyncns bluetooth caps dbus gdbm glib gnome* gtk ipv6 jack libsamplerate lirc orc qt4 speex ssl tcpd udev webrtc-aec -adrian-aec -doc -equalizer -gcov -native-headset (-neon) -ofono-headset (-oss) -realtime (-system-wide) (-systemd) {-test} -xen -zeroconf" ABI_X86="32 (64) (-x32)" 1,435 kB


#5
keitho2000

keitho2000

    Member

  • Members
  • PipPip
  • 15 posts

When I run the command portage tries to install pulseaudio like normal... And how is pulseaudio enabled globally, is it because you're using the desktop flavor?



#6
Oleg Vinichenko

Oleg Vinichenko

    Staff

  • Moderators
  • 357 posts

it is  not enough information given about failure. need complete build.log


www.funtoo.org

#7
keitho2000

keitho2000

    Member

  • Members
  • PipPip
  • 15 posts

Oh. I forgot...

Here it is:

 

Spoiler

 

Anyone who scrolled through all that deserves my respect

 

I haven't ever had to post something like this before so just tell me if you need anything else



#8
Oleg Vinichenko

Oleg Vinichenko

    Staff

  • Moderators
  • 357 posts

was it build.log? looks like it was config.log


www.funtoo.org

#9
j-g-

j-g-

    Advanced Member

  • Members
  • PipPipPip
  • 80 posts

was it build.log? looks like it was config.log

The build failed at configure phase would there be any more logs?
OP:
 
You can try to manually check if the configure phase is completing, and if not get the important log with this:
(try to run the build up to the configure phase using the portage user)

# sudo -u portage ebuild $(equery w pulseaudio) clean configure

if that fails with a similar error as the first you posted go into the build dir, I recommend as the portage user.

$ sudo -u portage bash

$ cd /var/tmp/portage/media-sound/pulseaudio/work/pulseaudio-${the version you are installing}/

and run :

$ ./configure  --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib64 --disable-silent-rules --disable-dependency-tracking --with-database=gdbm --enable-bluez5 --disable-bluez4 --disable-bluez5-native-headset --disable-bluez5-ofono-headset --localstatedir=/var --with-udev-rules-dir=//lib/udev/rules.d --disable-coreaudio-output --disable-esound --disable-solaris --disable-waveout --enable-largefile --enable-x11 --disable-adrian-aec --enable-asyncns --enable-glib2 --disable-oss-output --disable-oss-wrapper --enable-alsa --enable-dbus --disable-gcov --enable-gconf --enable-gtk3 --disable-jack --enable-ipv6 --disable-samplerate --disable-lirc --disable-neon-opt --enable-orc --enable-openssl --disable-systemd-daemon --disable-systemd-journal --disable-systemd-login --enable-tcpwrap --disable-default-build-tests --enable-udev --enable-hal-compat --enable-webrtc-aec --disable-xen --disable-avahi --with-caps --without-fftw --with-speex

(This is the line portage ran for you before)
The fail log of this should be what contains the info that matters if configure is what is failing.



#10
Sandro

Sandro

    Advanced Member

  • Members
  • PipPipPip
  • 334 posts
  • LocationSaronno, Via IV Novembre, 23 21047 Italy

[ot]

Oh .... I'm very glad that the the better users (the developers) wants to give an hand :) :) :).

I'm tryiong to install also Gnome 3.x n my system ..... using -Ofast".

I 'lll tell You if all works ok or if there are troubles.

[/ot]

 

Excuse me for my off topic, but I see thath there was only kdelibs and other two packages that doesn't compile with -Ofast but is necessary "-O2".

Forgive me for off topic :(; but I think may be an experiment that can be of interesting.

For now pulseaudio is compiled succesful addin new local flags.

 
[ebuild   R    ] media-sound/pulseaudio-5.99.3-r1  USE="X alsa alsa-plugin asyncns bluetooth caps dbus equalizer gdbm glib gnome gtk ipv6 jack libsamplerate lirc orc qt4 realtime speex ssl tcpd udev webrtc-aec -adrian-aec -doc -gcov -native-headset (-neon) -ofono-headset (-oss) (-system-wide) (-systemd) {-test} -xen -zeroconf" ABI_X86="32 (64) (-x32)" 0 kB
 

 

Good Work for All !!!!!! and excuse me .

 

Ciao Great !



#11
keitho2000

keitho2000

    Member

  • Members
  • PipPip
  • 15 posts

When I try to run the ./configure command, it fails after checking things. The last 2 lines are

 

checking for LIBSPEEX... no
configure: error: *** speex support not found
 

When I remove --with-speex, I am told that I should always use speex support.

 

And here is the rest of the relevant info:

 

The output of emerge -pqv '=media-sound/pulseaudio-5.99.3-r1':

Spoiler

 

My build log at /var/tmp/portage/media-sound/pulseaudio-5.99.3-r1/temp/build.log:

Spoiler

 

And my ebuild environment at /var/tmp/portage/media-sound/pulseaudio-5.99.3-r1/temp/environment:

Spoiler



#12
Sandro

Sandro

    Advanced Member

  • Members
  • PipPipPip
  • 334 posts
  • LocationSaronno, Via IV Novembre, 23 21047 Italy

Have You tried before:

# emerge --oneshot speex

?



#13
keitho2000

keitho2000

    Member

  • Members
  • PipPip
  • 15 posts

I oneshotted speex, and the compile worked. I was given a lot of errors, but the compile seemed to work. Can someone tell me if these are bad?

 

 

Spoiler

 

There were many similar errors, and the compile took a very long time.



#14
j-g-

j-g-

    Advanced Member

  • Members
  • PipPipPip
  • 80 posts
✓  Best Answer

I oneshotted speex, and the compile worked. I was given a lot of errors, but the compile seemed to work. Can someone tell me if these are bad?

 

 

Spoiler

 

There were many similar errors, and the compile took a very long time.

Did you re-run  the ebuild command 2 times from inside /var/tmp/portage/... the directories created get remove everytime you try to do a new build either using emerge  or ebuild ... clean, I have had similar errors when I forgot to cd out of the autogenerated directories.

Now that you have identified that the failure is in speex, report a bug so the dependecy get's added to the ebuild so this error doesn't happen to other people.

Since you emerged it with one-shot you shouldn't have any problems once it gets fixed. you can try from your home dir, to check the errors are because of what I tell you before.
$ sudo emerge --oneshot pulseaudio





Reply to this topic



  



Also tagged with one or more of these keywords: portage, sound, pulseaudio, alsa, gnome

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users