Jump to content

Photo

error installing ati-drivers

- - - - - Portage emerge ati xorg-server

3 replies to this topic

#1
milos9304

milos9304

    Newbie

  • Members
  • Pip
  • 1 posts

Portage displays an error when trying to install ati-drivers, but I am a newbie to *too Linux and my English is not well and I do not understand what is going on :(

 

Output of

emerge ati-drivers 

   is:

Calculating dependencies... done!
[ebuild  N     ] sys-power/acpid-2.0.22-r1  USE="(-selinux)"
[ebuild  N     ] x11-libs/libvdpau-0.8  USE="dri -doc {-test}"
[ebuild  N     ] x11-proto/xf86miscproto-0.9.3
[ebuild  N     ] virtual/linux-sources-2.6  USE="-hardened"
[ebuild  N     ] app-admin/eselect-opencl-1.1.0-r3
[ebuild     UD ] x11-base/xorg-server-1.15.1 [1.16.0]
[ebuild  N     ] x11-libs/libva-1.3.1  USE="X drm opengl -egl -vdpau -wayland" VIDEO_CARDS="-dummy -fglrx -intel -nvidia"
[ebuild  N     ] x11-drivers/ati-drivers-14.4_p1  USE="modules (multilib) vaapi -debug -pax_kernel -qt4 -static-libs"
[ebuild  N     ] x11-libs/xvba-video-0.8.0-r6  USE="opengl -debug"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.15.1::gentoo, ebuild scheduled for merge) pulled in by
    <=x11-base/xorg-server-1.15.49[-minimal] required by (x11-drivers/ati-drivers-14.4_p1::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                            
  (x11-base/xorg-server-1.16.0::gentoo, installed) pulled in by                                                                                                                                                             
    x11-base/xorg-server:0/1.16.0= required by (x11-drivers/xf86-video-ati-7.4.0::gentoo, installed)                                                                                                                        
    x11-base/xorg-server:0/1.16.0= required by (x11-libs/glamor-0.6.0-r1::gentoo, installed)                                                                                                                                
    x11-base/xorg-server:0/1.16.0= required by (x11-drivers/xf86-input-evdev-2.8.4::gentoo, installed)        


#2
duncan.britton

duncan.britton

    Member

  • Members
  • PipPip
  • 13 posts

It looks like you already have some drivers installed for your graphics card that are pulling in a later version of Xorg than the ati-drivers can support:

x11-drivers/xf86-video-ati-7.4.0::gentoo

If you only want to have the ati-drivers, change your /etc/portage/make.conf to contain the following:

VIDEO_CARDS="fglrx"

After doing that, you can try unmerging xf86-video-ati, glamor, and xf86-input-evdev. Then, run an "emerge --update --newuse --deep --with-bdeps=y @world". This should pull in the ati-drivers without all of those nasty conflicts that you are getting. Also, check out http://www.funtoo.or...t_Video_Drivers . Hope this helped!


  • cuchumino likes this

#3
cuchumino

cuchumino

    Member

  • Members
  • PipPip
  • 28 posts

what duncan.britton said, plus you should blacklist the following.

 

 

/etc/modprobe.d/blacklist.conf

blacklist radeon

If you don't do this before reboot, you might run into trouble. the radeon kernel module will load, and block fglrx from loading.

 

This in turn can bring you massive headaches.

 

Hope this helps!



#4
uudruid74

uudruid74

    Advanced Member

  • Members
  • PipPipPip
  • 134 posts
  • LocationDallas, TX USA

I'm getting the same problem on a brand-new install.  I want to install both the radeon and fglrx drivers (in case I have problems and need to go back to the open-source, but the proprietary drivers work around other bugs in more important software that I NEED - lyx).  Gentoo can switch between them with eselect right? 

 

And a version of fgrlx that works with 1.16 is already in "testing" just not yet downloadable from ATIs site (at least I can't find 'em).  But archlinux has a package for it!   How would one go about making ab ebuild for this and installing it?  This would allow Xorg 1.16 and the latest released kernel (3.17), and would solve the above issue in cleaner manner (IMO).

 

I just got all this stuff installed and haven't changed my list of video cards, so I'm kinda mad that I have to unmerge stuff that it automatically merged with no guarantee that it won't pull in the same stuff all over again.  My poor CPU has been thrashing away for almost 2 days (I'm experimenting with getting everything installed that I need before I reboot - running a different Linux right now and I don't want the computer to be down for more than 5 mins - I think I can pull it off .. but that means a compile of full desktop, gnome, libreoffice, etc)   :(

 

Help, suggestions, comments?  I really want to just grab this : https://aur.archlinu.../catalyst-test/

and make an ebuild, but I haven't made an ebuild in about 10 years. It has patches and such, but not sure if any of it is arch specific.


https://github.com/u.../bashTheObjects -- Object Oriented Programming in BASH !!
https://eddon.systems -- Stuff I'm Working on.




Reply to this topic



  



Also tagged with one or more of these keywords: Portage, emerge, ati, xorg-server

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users