Jump to content

Photo

upower and GOBJECT_INTROSPECTION_CHECK - syntax error in configure?

- - - - - upower

4 replies to this topic

#1
kikko

kikko

    Newbie

  • Members
  • Pip
  • 3 posts
  • LocationMilan, Italy

I'm installing Funtoo on my laptop, but I'm facing a strange error during the emerge of networkmanager: 

 

checking whether to enable maintainer-specific portions of Makefiles... yes

checking whether make supports nested variables... (cached) yes
./configure: line 3103: syntax error near unexpected token `0.9.9'
./configure: line 3103: `GOBJECT_INTROSPECTION_CHECK(0.9.9)'
 

   * Messages for package sys-power/upower-20140423:

 
 * ERROR: sys-power/upower-20140423 failed (prepare phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line  93:  Called src_prepare
 *   environment, line 2768:  Called die
 * The specific snippet of code:
 *           ./autogen.sh || die;
 * 
 * If you need support, post the output of `emerge --info '=sys-power/upower-20140423'`,
 * the complete build log and the output of `emerge -pqv '=sys-power/upower-20140423'`.
 * The complete build log is located at '/var/tmp/portage/sys-power/upower-20140423/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-power/upower-20140423/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-power/upower-20140423/work/upower-20140423'
 * S: '/var/tmp/portage/sys-power/upower-20140423/work/upower-20140423'
 
 Introspection USE flag is disabled:
 
  [ebuild  N    ] sys-power/upower-20140423  USE="deprecated -introspection -ios"
 
but the configure script seem to look for this GOBJECT_INTROSPECTION_CHECK function  :wacko:
 
I've already tried adding the USE flag "deprecated" to the /etc/portage/package.use (as suggested here http://forums.funtoo...-an-xml-parser/)
 
Any suggestion?

Attached Files



#2
dantrell

dantrell

    Advanced Member

  • Members
  • PipPipPip
  • 36 posts

I could not reproduce your build failure with or without the introspection USE flag enabled. Please mask sys-power/upower-20140423 and try sys-power/upower-0.99.0-r1. If that works, then I'm going to need more information. What version of sys-deve/autoconf and sys-devel/automake do you have installed?



#3
kikko

kikko

    Newbie

  • Members
  • Pip
  • 3 posts
  • LocationMilan, Italy
Dantrell, emerge of the upower-0.99.0-r1 succeeded! (thank you very much)

Anyway, here are the versions of autoconf and automake I have on my system:

- sys-devel/autoconf 2.69
- sys-devel/automake 1.13.4

Please let me know if you need further info

#4
morphmex

morphmex

    Advanced Member

  • Members
  • PipPipPip
  • 44 posts
  • LocationLivorno- Italy

Same problem, fixed masking ...



#5
romikb

romikb

    Newbie

  • Members
  • Pip
  • 5 posts

Same problem on clean just installed system.

I set kde flavor, try update world and get this error.





Reply to this topic



  



Also tagged with one or more of these keywords: upower

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users