Jump to content

Photo

kernel installation questions

- - - - -

4 replies to this topic

#1
noone

noone

    Member

  • Members
  • PipPip
  • 11 posts

hello,

my /boot

is empty  and eselect list kernel is generating an error after installing gentoo-sources:

# emerge gentoo-sources

1. eselect list kernel

!!! Error: Can't load module list
2. eselect kernel set 2 (checked reflecting symlink linux -> linux-4.13.1-gentoo)
4. make xconfig

5. cp /usr/src/linux/.config /usr/src/linux/config
6. make modules_prepare
7. genkernel --kernel-config=/usr/src/linux/config all
8. edit /boot/grub/grub.cfg
9. reboot & pray

 

After installing new kernel I was able to edit /boot/grub/grub.cfg because /boot was populated. However after reboot /boot is empty.

Because Funtoo boots and boot menu reflects my changes then config files are hidden somewhere. However I would like to know where boot config files are located in the case of post boot changes that I would like to add. Unless there is another way of installing kernel and updating config files?

 

thank you



#2
dhudson

dhudson

    Member

  • Members
  • PipPip
  • 14 posts

/boot is not automatically mounted by default but was by genkernel,

will have to put mount point in fstab i think.

or do a manual mount when needed.

 

dave



#3
noone

noone

    Member

  • Members
  • PipPip
  • 11 posts

/boot is not automatically mounted by default but was by genkernel,

will have to put mount point in fstab i think.

or do a manual mount when needed.

 

dave

I just did not pay attention to noauto option in fstab!

 

thank you,

 

p.s.

do you why eselect generates this error?

eselect list kernel

!!! Error: Can't load module list



#4
Sandro

Sandro

    Advanced Member

  • Members
  • PipPipPip
  • 369 posts
  • LocationSaronno, Via IV Novembre, 23 21047 Italy

eselect list kernel

!!! Error: Can't load module list

 

is wrong

# eselect kernel list
then
# eselect kernel set N

eselect  kernel set N (Iwith N = the mumber associated at the kernel that you want to compile.

 

:)

 

For example you can change the "noauto" ....

this is my /etc/fstab ... just for a comparison

 

sandro@ci74771ht ~ $ cat /etc/fstab

# /etc/fstab: static file system information.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
#
# See the manpage fstab(5) for more information.
#                                                                                                                                                                                                                                                                                                                           
# <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>                                                                                                                                                                                                                                         
                                                                                                                                                                                                                                                                                                                            
/dev/sdb1       /boot                   ext4            noatime                                         1 2                                                                                                                                                                                                                 
/dev/sdb2       none                    swap            sw                                              0 0                                                                                                                                                                                                                 
/dev/sdb3       /                       ext4            noatime                                         0 1                                                                                                                                                                                                                 
/dev/sdb5       /home                   ext4            noatime                                         1 2                                                                                                                                                                                                                 
/dev/sdb6       /mnt/Volume             ntfs-3g         defaults                                        0 0                                                                                                                                                                                                                 
#/dev/cdrom     /mnt/cdrom              auto            noauto,ro                                       0 0                                                                                                                                                                                                                 
shm             /dev/shm                tmpfs           defaults                                        0 0                                                                                                                                                                                                                 
tmpfs           /var/tmp/portage        tmpfs           gid=portage,uid=portage,mode=775,noatime        0 0

The last raw in /etc/fstab is for compile in RAM; but i've 16 GiB .... i don't know your Amount of memory :)

Ciao :)



#5
noone

noone

    Member

  • Members
  • PipPip
  • 11 posts

is wrong

# eselect kernel list
then
# eselect kernel set N

eselect  kernel set N (Iwith N = the mumber associated at the kernel that you want to compile.

 

:)

 

For example you can change the "noauto" ....

this is my /etc/fstab ... just for a comparison

 

sandro@ci74771ht ~ $ cat /etc/fstab

# /etc/fstab: static file system information.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
#
# See the manpage fstab(5) for more information.
#                                                                                                                                                                                                                                                                                                                           
# <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>                                                                                                                                                                                                                                         
                                                                                                                                                                                                                                                                                                                            
/dev/sdb1       /boot                   ext4            noatime                                         1 2                                                                                                                                                                                                                 
/dev/sdb2       none                    swap            sw                                              0 0                                                                                                                                                                                                                 
/dev/sdb3       /                       ext4            noatime                                         0 1                                                                                                                                                                                                                 
/dev/sdb5       /home                   ext4            noatime                                         1 2                                                                                                                                                                                                                 
/dev/sdb6       /mnt/Volume             ntfs-3g         defaults                                        0 0                                                                                                                                                                                                                 
#/dev/cdrom     /mnt/cdrom              auto            noauto,ro                                       0 0                                                                                                                                                                                                                 
shm             /dev/shm                tmpfs           defaults                                        0 0                                                                                                                                                                                                                 
tmpfs           /var/tmp/portage        tmpfs           gid=portage,uid=portage,mode=775,noatime        0 0

The last raw in /etc/fstab is for compile in RAM; but i've 16 GiB .... i don't know your Amount of memory :)

Ciao :)

Thank you for helping. Running portage in RAM is great idea (I do the same with CRUX compiling). I just did not know how much RAM I would need for portage. I run Funtoo as virtual guest and I can increase allowed RAM to 16GB.





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users