Jump to content

Photo

ModemManager's boot error


1 reply to this topic

#1
znavko

znavko

    Member

  • Members
  • PipPip
  • 15 posts

Hello! I try to install funtoo stage3 current standard in Lenovo G50-30 but first boot into my system displays the error:

 

"ModemManager: Couldn't check support for device at '/sys/devices/pci:000...xxx...000' not supported by any plugin"

 

and the system is waiting any key. I press any key and can see login in shell. I need to authorize and type slim despite my xdm configured to start slim desktop. Slim, Xfce start and work ok. Networkmanager can connect to wifi.

 

I've read it is possible to switch of  bug report in kernel configuration, also may be I can compile kernel with device support??

 

Please, help to the novice?



#2
znavko

znavko

    Member

  • Members
  • PipPip
  • 15 posts

Dear developers! I had this: boot with systemrescuecdm chroot into funtoo, installed slim,xfce4-meta, networkmanager, run commands

rc-update add NetworkManager default
rc-update add xdm default
rc-update add dbus default
rc

but the `rc` command displayed errors that I "run it on system that was not boot, it may be chroot..." So I rebooted to my new funtoo and run rc. It say me error: 'netmount will start after networkmanager has started'.

 

Think I catch the reason of my own problem:

 

I boot into my new funtoo manually starting slim and dug this:

# rc-update -s
       NetworkManager |      default                 
               binfmt | boot                         
             bootmisc | boot                         
                 dbus |      default                 
                devfs |                       sysinit
               dhcpcd |      default                 
                dmesg |                       sysinit
                 fsck | boot                         
             hostname | boot                         
              hwclock | boot                         
              keymaps | boot                         
            killprocs |              shutdown        
    kmod-static-nodes |                       sysinit
                local |      default                 
           localmount | boot                         
             loopback | boot                         
              modules | boot                         
             mount-ro |              shutdown        
                 mtab | boot                         
             netmount |      default                 
               procfs | boot                         
                 root | boot                         
            savecache |              shutdown        
                 sshd |      default                 
                 swap | boot                         
               sysctl | boot                         
                sysfs |                       sysinit
         termencoding | boot                         
                 udev |                       sysinit
              urandom | boot                         
localhost ~ # man xdm
No manual entry for xdm
localhost ~ # nano /etc/conf.d/xdm
localhost ~ # rc-update add xdm default
 * service xdm added to runlevel default
localhost ~ #  rc-update add dbus default
 * rc-update: dbus already installed in runlevel `default'; skipping
localhost ~ # rc
 * Caching service dependencies ...                                       [ ok ]
 * Setting up slim ...
 * start-stop-daemon: /usr/bin/slim is already running
 * ERROR: could not start the Display Manager                             [ ok ]


localhost ~ # rc-update -s
       NetworkManager |      default                 
               binfmt | boot                         
             bootmisc | boot                         
                 dbus |      default                 
                devfs |                       sysinit
               dhcpcd |      default                 
                dmesg |                       sysinit
                 fsck | boot                         
             hostname | boot                         
              hwclock | boot                         
              keymaps | boot                         
            killprocs |              shutdown        
    kmod-static-nodes |                       sysinit
                local |      default                 
           localmount | boot                         
             loopback | boot                         
              modules | boot                         
             mount-ro |              shutdown        
                 mtab | boot                         
             netmount |      default                 
               procfs | boot                         
                 root | boot                         
            savecache |              shutdown        
                 sshd |      default                 
                 swap | boot                         
               sysctl | boot                         
                sysfs |                       sysinit
         termencoding | boot                         
                 udev |                       sysinit
              urandom | boot                         
                  xdm |      default                 
localhost ~ # 

So I had to add services in rc-update again and run `rc` again to have a success. I'll try to reboot when libreoffice and other apps will compiled. And think Slim goes automatically.

 

 

But I still need your support with ModemManager Error. Cause I have this error in both my laptops.

 

One remark: this overloaded with Java forum causes my mouse stops for 2-3 seconds. Such a problem was before when I browsed web-sites: system was stopped, screen froze and mouse did not move and only reboot helped.





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users