Jump to content

Photo

About "microcode"


Best Answer cardinal , 17 August 2017 - 09:01 PM

Remove  early_ucode.cpio  from your bootloader configuration.

 

https://wiki.gentoo....Intel_microcode

Go to the full post »


8 replies to this topic

#1
Sandro

Sandro

    Advanced Member

  • Members
  • PipPipPip
  • 367 posts
  • LocationSaronno, Via IV Novembre, 23 21047 Italy

Hi to All

At startup i obtain at first

error: file /early_ucode.cpio not found
 
Press any key to continue

My system:

MB :  Asus Z97-AR

cpu (socket 1150) intel core i7 4771 @3,5 GHz

Ram :  4 x 4 GiB (Evo Potenza)

Videocard: MSI nVidia GTX 660

 

In the past I removed the service
microcode_ctl
As the microcode update did "crash" the system.
 
What should I do to solve it?
 
Thank you.


#2
cardinal

cardinal

    Advanced Member

  • Members
  • PipPipPip
  • 252 posts
✓  Best Answer

Remove  early_ucode.cpio  from your bootloader configuration.

 

https://wiki.gentoo....Intel_microcode


  • Sandro likes this

#3
Sandro

Sandro

    Advanced Member

  • Members
  • PipPipPip
  • 367 posts
  • LocationSaronno, Via IV Novembre, 23 21047 Italy

Great Cardinal \o/

 

For You there are "no secrets" about *too :)

 

But, only a question: could be a good experiment try to update ucode for my cpu ? or it's better not updating it ?

 

Thanx for All .... "Genius" :)



#4
cardinal

cardinal

    Advanced Member

  • Members
  • PipPipPip
  • 252 posts

Build microcode cpio with iucode_tool and load as initrd, If there is a problem disable in the grub menu prior to boot.


  • niltsiar and McQ like this

#5
niltsiar

niltsiar

    Newbie

  • Members
  • Pip
  • 7 posts

That's how I do it and it's working great for my i7-6700


  • cardinal likes this

#6
Sandro

Sandro

    Advanced Member

  • Members
  • PipPipPip
  • 367 posts
  • LocationSaronno, Via IV Novembre, 23 21047 Italy

Onh ... now it seems that works also with my 4771 :)

 

However ... Thanx a lot for Your aid :)



#7
Sandro

Sandro

    Advanced Member

  • Members
  • PipPipPip
  • 367 posts
  • LocationSaronno, Via IV Novembre, 23 21047 Italy

Sincerely i've make an aexperiment ... to try to enable the ucode update ...

Installing  "microcode-ctl" , i've no the relative sevice.

andro@ci74771ht ~ $ rc-config list |grep microcode 
sandro@ci74771ht ~ $ 

then ... i think that microcode is not charged.

 

Thx for suggestions :)



#8
cardinal

cardinal

    Advanced Member

  • Members
  • PipPipPip
  • 252 posts

Verify microcode is loaded after using "Early microcode" method:

rj@funtoo ~ $ dmesg | grep microcode
[    0.000000] microcode: CPU0 microcode updated early to revision 0xa4, date = 2010-10-02
[    0.009999] microcode: CPU1 microcode updated early to revision 0xa4, date = 2010-10-02
[    0.740346] microcode: CPU0 sig=0x6fd, pf=0x1, revision=0xa4
[    0.740472] microcode: CPU1 sig=0x6fd, pf=0x1, revision=0xa4
[    0.740640] microcode: Microcode Update Driver: v2.01 <tigran@aivazian.fsnet.co.uk>, Peter Oruba

https://wiki.gentoo....Intel_microcode :

The microcode-ctl utility has been deprecated as of version 1.28-r1(Gentoo unstable)[1] and no longer contains the init script. It also does not work on certain CPUs such as Intel Haswells, you should switch to the "Early microcode" method explained directly below. If however you wish to continue using microcode-ctl please skip to the "Microcode-ctl" section near the bottom of this page.



#9
Sandro

Sandro

    Advanced Member

  • Members
  • PipPipPip
  • 367 posts
  • LocationSaronno, Via IV Novembre, 23 21047 Italy

I've this output :|

 

sandro@ci74771ht ~ $ dmesg|grep microcode
[    0.894194] microcode: sig=0x306c3, pf=0x2, revision=0x19
[    0.894381] microcode: Microcode Update Driver: v2.01 <tigran@aivazian.fsnet.co.uk>, Peter Oruba




Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users