Jump to content

Photo

upower Wants an XML Parser

upower

Best Answer dantrell , 23 July 2014 - 06:27 AM

You have a few things going on here. You updated perl but failed to run "perl-cleaner --all" (or --reallyall). Until you do, upower isn't the only package that will fail to compile. Please take care of that first and then see how things go. On the note of upower, because of the work I have been doing in Funtoo, upower-pm-utils is no longer needed. You can simply build upower with the deprecated USE flag and achieve the same effect. This is done for you if you are using GNOME and have enabled the mix-in.

 

Secondly, net-analyzer/snortsam-2.70 does indeed fail to build, I will be taking care of this issue over at FL-1408.

Go to the full post »


3 replies to this topic

#1
dougbmorris

dougbmorris

    Advanced Member

  • Members
  • PipPipPip
  • 43 posts

I get a compile problem when I try to update upower as part of my @world update. I removed the upower package to try and install it. I tried upower-pm-utils because of what I found in this forum that was recommended for a different upower problem. Didn't help this.

 

I want to show that I read the eselect news. There was the recent issue with in the news, but I can't read it now. My issue with upower is recent. I did a successful @world update one or two weeks ago. The news item is a month old, and I can't read it now for reasons I don't know.

Computer me # eselect news list
News items:
  [1]      2009-04-18  (2009-04-18-java-config-wrapper-0.16 - removed?)
  [2]      2010-08-01  (2010-08-01-as-needed-default - removed?)
  [3]      2012-03-16  (2012-03-16-udev-181-unmasking - removed?)
  [4]      2012-05-21  (2012-05-21-portage-config-protect-if-modified - removed?)
  [5]      2012-09-01  Funtoo 1.0 Profiles
  [6]      2012-09-09  (2012-09-09-make.conf-and-make.profile-move - removed?)
  [7]      2012-11-06  (2012-11-06-PYTHON_TARGETS-deployment - removed?)
  [8]      2012-12-01  Funtoo stable branch toolchain update
  [9]      2013-01-23  (2013-01-23-udev-upgrade - removed?)
  [10]     2013-03-29  (2013-03-29-udev-upgrade - removed?)
  [11]     2013-04-22  Funtoo kmod migration
  [12]     2013-06-07  (2013-06-07-portage-preserve-libs-default - removed?)
  [13]     2013-06-30  (2013-06-30-cups16 - removed?)
  [14]     2013-08-07  (2013-08-07-vanilla-sources-stablization-policy - removed?)
  [15]     2013-08-23  (2013-08-23-emerge-language - removed?)
  [16]     2013-09-27  (2013-09-27-initramfs-required - removed?)
  [17]     2013-11-07  (2013-11-07-python-exec-package-move - removed?)
  [18]     2014-02-25  (2014-02-25-udev-upgrade - removed?)
  [19]     2014-06-03  (2014-06-03-upower-loses-hibernate-suspend-to-systemd - removed?)
Computer me #

See how it asks 'removed?' I don't remember removing any news, but then I might have neurotic alheimers from too much screen radiation.

 

BTW, I just used the BBCode for \[code\]. Where the heck is it with this new format? Does not show in the list for Special BBCode. Having to remove the double spacing that got added when I pasted outputs was a pain in the ass. Anyone know why I got double spacing? I manually removed it, at least I hope so.

 

Anyway, if the upower compile fail relates to upower loses hibernate, sorry for my lack of prior planning.

 

I seem to need upower for my xfce desktop:

Computer me # equery d upower
 * These packages depend on upower:
xfce-base/xfce4-session-4.11.0-r2 (udev ? >=sys-power/upower-0.9.23)
xfce-base/xfce4-settings-4.11.2-r1 (udev ? >=sys-power/upower-0.9.23)
xfce-extra/xfce4-power-manager-1.3.0 (>=sys-power/upower-0.9.23)
Computer me #

This is my emerge update issue (originally I was updating my @world with all the bells and whistles, 'emerge -uDN --with-bdeps=y --autounmask-write @world --ask'):

Computer me # emerge -1 upower

...

checking for gmsgfmt... /usr/bin/gmsgfmt
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.18.2
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool
 * ERROR: sys-power/upower-20140423 failed (prepare phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  93:  Called src_prepare
 *   environment, line 2793:  Called die
 * The specific snippet of code:
 *           ./autogen.sh || die;
 *
 * If you need support, post the output of `emerge --info '=sys-power/upower-20140423'`,
 * the complete build log and the output of `emerge -pqv '=sys-power/upower-20140423'`.
 * The complete build log is located at '/var/tmp/portage/sys-power/upower-20140423/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-power/upower-20140423/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-power/upower-20140423/work/upower-20140423'
 * S: '/var/tmp/portage/sys-power/upower-20140423/work/upower-20140423'

>>> Failed to emerge sys-power/upower-20140423, Log file:

>>>  '/var/tmp/portage/sys-power/upower-20140423/temp/build.log'

 * Messages for package sys-power/upower-20140423:

 * ERROR: sys-power/upower-20140423 failed (prepare phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  93:  Called src_prepare
 *   environment, line 2793:  Called die
 * The specific snippet of code:
 *           ./autogen.sh || die;
 *
 * If you need support, post the output of `emerge --info '=sys-power/upower-20140423'`,
 * the complete build log and the output of `emerge -pqv '=sys-power/upower-20140423'`.
 * The complete build log is located at '/var/tmp/portage/sys-power/upower-20140423/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-power/upower-20140423/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-power/upower-20140423/work/upower-20140423'
 * S: '/var/tmp/portage/sys-power/upower-20140423/work/upower-20140423'
Computer me #
Computer me # emerge --info '=sys-power/upower-20140423'
Portage 2.3.6-r8 (funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-4.8.2, glibc-2.18-r1, 3.15.6 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.15.6-x86_64-Intel-R-_Core-TM-_i5-2430M_CPU_@_2.40GHz-with-gentoo-2.2.0
KiB Mem:     3966984 total,   1782424 free
KiB Swap:    2097148 total,   2097148 free
Timestamp of tree: Unknown
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45-r1
dev-java/java-config:     2.2.0-r1000
dev-lang/python:          2.7.8-r1000, 3.3.5-r1000
dev-util/cmake:           2.8.12.2-r1
sys-apps/baselayout:      2.2.0-r6
sys-apps/openrc:          0.12.3-r3
sys-apps/sandbox:         2.6-r2
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.8.2-r2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.18-r1
Repositories: gentoo java
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=corei7 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
MAKEOPTS="-j5"
KGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/java"
SYNC="git://github.com/funtoo/ports-2012.git"
SYNC_USER="root"
USE="X acl alsa amd64 apng berkdb bzip2 cdr consolekit cracklib crypt cups cxx dbus dri dvd dvdr dvdread flac gcj gdbm gif gpm gtk iconv icu ipv6 java jpeg lame libnotify lock mad mmx modules mp3 mpeg mudflap multilib ncurses nls nptl nsplugin ogg opengl openmp pam pcre png policykit pppd python readline resolvconf sasl session sse sse2 ssl startup-notification svg tcpd thunar tiff truetype udev unicode vorbis wavpack win32codecs xml zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel ice1724 intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authn_core authz_core socache_shmcb unixd" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_ABIS="2.7 3.3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby19 ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="radeon intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC_UMASK

Computer me #
Computer me # emerge -pqv '=sys-power/upower-20140423'
[ebuild  N    ] sys-power/upower-20140423  USE="-deprecated -introspection -ios"
Computer me #
Computer me # emerge -1 upower-pm-utils

...

checking for gmsgfmt... /usr/bin/gmsgfmt
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.18.2
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-power/upower-pm-utils-0.9.23-r2/work/upower-0.9.23/config.log
 * ERROR: sys-power/upower-pm-utils-0.9.23-r2 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_configure
 *        environment, line 1942:  Called econf '--libexecdir=/usr/lib/upower' '--localstatedir=/var' '--disable-introspection' '--disable-static' '--enable-deprecated' '--enable-man-pages' '--disable-tests' '--with-html-dir=/usr/share/doc/upower-pm-utils-0.9.23-r2/html' '--with-backend=linux' '--without-idevice' '--with-systemdutildir=/usr/lib/systemd' '--with-systemdsystemunitdir=/usr/lib/systemd/system'
 *   phase-helpers.sh, line  521:  Called die
 * The specific snippet of code:
 *               die "econf failed"
 *
 * If you need support, post the output of `emerge --info '=sys-power/upower-pm-utils-0.9.23-r2'`,
 * the complete build log and the output of `emerge -pqv '=sys-power/upower-pm-utils-0.9.23-r2'`.
 * The complete build log is located at '/var/tmp/portage/sys-power/upower-pm-utils-0.9.23-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-power/upower-pm-utils-0.9.23-r2/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-power/upower-pm-utils-0.9.23-r2/work/upower-0.9.23'
 * S: '/var/tmp/portage/sys-power/upower-pm-utils-0.9.23-r2/work/upower-0.9.23'

>>> Failed to emerge sys-power/upower-pm-utils-0.9.23-r2, Log file:

>>>  '/var/tmp/portage/sys-power/upower-pm-utils-0.9.23-r2/temp/build.log'

 * Messages for package sys-power/upower-pm-utils-0.9.23-r2:

 * ERROR: sys-power/upower-pm-utils-0.9.23-r2 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_configure
 *        environment, line 1942:  Called econf '--libexecdir=/usr/lib/upower' '--localstatedir=/var' '--disable-introspection' '--disable-static' '--enable-deprecated' '--enable-man-pages' '--disable-tests' '--with-html-dir=/usr/share/doc/upower-pm-utils-0.9.23-r2/html' '--with-backend=linux' '--without-idevice' '--with-systemdutildir=/usr/lib/systemd' '--with-systemdsystemunitdir=/usr/lib/systemd/system'
 *   phase-helpers.sh, line  521:  Called die
 * The specific snippet of code:
 *               die "econf failed"
 *
 * If you need support, post the output of `emerge --info '=sys-power/upower-pm-utils-0.9.23-r2'`,
 * the complete build log and the output of `emerge -pqv '=sys-power/upower-pm-utils-0.9.23-r2'`.
 * The complete build log is located at '/var/tmp/portage/sys-power/upower-pm-utils-0.9.23-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-power/upower-pm-utils-0.9.23-r2/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-power/upower-pm-utils-0.9.23-r2/work/upower-0.9.23'
 * S: '/var/tmp/portage/sys-power/upower-pm-utils-0.9.23-r2/work/upower-0.9.23'

Computer me #

Maybe I need libxml-perl? Other possible solutions?

Computer me # esearch "XML.*perl"
[ Results for search key : XML.*perl ]
[ Applications found : 1 ]

*  dev-perl/libxml-perl
      Latest version available: 0.80.0
      Latest version installed: [ Not Installed ]
      Size of downloaded files: 62 kB
      Homepage:    http://search.cpan.org/dist/libxml-perl/
      Description: Collection of Perl modules for working with XML
      License:     || ( Artistic GPL-1 GPL-2 GPL-3 )
 
Computer me #

Does it look like there is a missing dependency in an ebuild? I am not familiar with them. Anything I attempt to learn is days of frustration. My latest bouts with masochism are with snort. I really envy you 140+ IQ guys.



#2
dougbmorris

dougbmorris

    Advanced Member

  • Members
  • PipPipPip
  • 43 posts

Addendum: My attempt to install snortsam failed in a similar way, but not with a concern with an XML parser. This time is refers to pthread_create. I have no &@(%ing idea at this point.

 

Ideas?

Computer ugh # emerge snortsam
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) net-analyzer/snortsam-2.70
 * snortsam-src-2.70.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                       [ ok ]
>>> Unpacking source...
>>> Unpacking snortsam-src-2.70.tar.gz to /var/tmp/portage/net-analyzer/snortsam-2.70/work
>>> Source unpacked in /var/tmp/portage/net-analyzer/snortsam-2.70/work
>>> Preparing source in /var/tmp/portage/net-analyzer/snortsam-2.70/work/snortsam ...
 * Applying snortsam-2.70-gentoo.patch ...                                                                                                             [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/net-analyzer/snortsam-2.70/work/snortsam ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/net-analyzer/snortsam-2.70/work/snortsam ...
-------------------------------------------------------------------------------
Building SnortSam (release)
-------------------------------------------------------------------------------
x86_64-pc-linux-gnu-gcc -march=corei7 -O2 -pipe -DLinux -Wl,-O1 -Wl,--sort-common -Wl,--as-needed -lpthread snortsam.c twofish.c ssp_ciscoacl.c ssp_cisco_nullroute.c ssp_cisco_nullroute2.c ssp_email.c ssp_forward.c ssp_fwexec.c ssp_fwsam.c ssp_netscreen.c ssp_opsec.c ssp_pix.c ssp_snmp_interface_down.c ssp_wgrd.c ssp_ipchains.c ssp_iptables.c ssp_ebtables.c -Wl,-O1 -Wl,--sort-common -Wl,--as-needed -o ../snortsam
/var/tmp/portage/net-analyzer/snortsam-2.70/temp/ccSZPnFx.o: In function `getout.part.4':
snortsam.c:(.text+0x1cbc): undefined reference to `pthread_cancel'
/var/tmp/portage/net-analyzer/snortsam-2.70/temp/ccSZPnFx.o: In function `queuehandler':
snortsam.c:(.text+0x3bc0): undefined reference to `pthread_create'
snortsam.c:(.text+0x3c7c): undefined reference to `pthread_create'
collect2: error: ld returned 1 exit status
 * ERROR: net-analyzer/snortsam-2.70 failed (compile phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  93:  Called src_compile
 *   environment, line 2198:  Called die
 * The specific snippet of code:
 *       sh makesnortsam.sh || die
 *
 * If you need support, post the output of `emerge --info '=net-analyzer/snortsam-2.70'`,
 * the complete build log and the output of `emerge -pqv '=net-analyzer/snortsam-2.70'`.
 * The complete build log is located at '/var/tmp/portage/net-analyzer/snortsam-2.70/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-analyzer/snortsam-2.70/temp/environment'.
 * Working directory: '/var/tmp/portage/net-analyzer/snortsam-2.70/work/snortsam'
 * S: '/var/tmp/portage/net-analyzer/snortsam-2.70/work/snortsam'

>>> Failed to emerge net-analyzer/snortsam-2.70, Log file:

>>>  '/var/tmp/portage/net-analyzer/snortsam-2.70/temp/build.log'

 * Messages for package net-analyzer/snortsam-2.70:

 * ERROR: net-analyzer/snortsam-2.70 failed (compile phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  93:  Called src_compile
 *   environment, line 2198:  Called die
 * The specific snippet of code:
 *       sh makesnortsam.sh || die
 *
 * If you need support, post the output of `emerge --info '=net-analyzer/snortsam-2.70'`,
 * the complete build log and the output of `emerge -pqv '=net-analyzer/snortsam-2.70'`.
 * The complete build log is located at '/var/tmp/portage/net-analyzer/snortsam-2.70/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-analyzer/snortsam-2.70/temp/environment'.
 * Working directory: '/var/tmp/portage/net-analyzer/snortsam-2.70/work/snortsam'
 * S: '/var/tmp/portage/net-analyzer/snortsam-2.70/work/snortsam'
Computer ugh # equery l -p portage
 * Searching for portage ...
[-P-] [  ] sys-apps/portage-2.3.5-r7:0
[-P-] [  ] sys-apps/portage-2.3.5-r8:0
[-P-] [  ] sys-apps/portage-2.3.6-r1:0
[-P-] [  ] sys-apps/portage-2.3.6-r2:0
[-P-] [  ] sys-apps/portage-2.3.6-r4:0
[-P-] [  ] sys-apps/portage-2.3.6-r5:0
[-P-] [  ] sys-apps/portage-2.3.6-r7:0
[IP-] [  ] sys-apps/portage-2.3.6-r8:0
[-P-] [M ] sys-apps/portage-2.3.6-r9:0
Computer ugh #


#3
dantrell

dantrell

    Advanced Member

  • Members
  • PipPipPip
  • 36 posts
✓  Best Answer

You have a few things going on here. You updated perl but failed to run "perl-cleaner --all" (or --reallyall). Until you do, upower isn't the only package that will fail to compile. Please take care of that first and then see how things go. On the note of upower, because of the work I have been doing in Funtoo, upower-pm-utils is no longer needed. You can simply build upower with the deprecated USE flag and achieve the same effect. This is done for you if you are using GNOME and have enabled the mix-in.

 

Secondly, net-analyzer/snortsam-2.70 does indeed fail to build, I will be taking care of this issue over at FL-1408.



#4
dougbmorris

dougbmorris

    Advanced Member

  • Members
  • PipPipPip
  • 43 posts

Thanks, dantrell! Got both packages 'upower' and 'snortsam' to install.

 

I noticed when I installed snortsame that it instructed in the output that I set USE flag 'snortsam' on snort and recompile snort. I tried adding snortsam as a USE flag on snort in two ways:

1) New file /etc/portage/package.use.force with the single line: net-analyzer/snort snortsam

2) Added 'snortsam' flag to my USE variable in /etc/portage/make.config: USE="gtk snortsam" (not showing every flag)

After each change, I ran: emerge -uDN --with-bdeps=y --autounmask-write --ask @world

And each time I got no updates to do after all the dependencies were considered.

 

I notice that there is no snortsam flag listed in my file /usr/portage/profiles/use.desc . Perhaps I did not really see a message to apply a snortsam USE flag. I could be suffering from scroll blindness. After a week, I can run: 'snort -v --daq-dir /usr/lib64/daq -i wlan0 -A full'. Was hoping for a gui frontend to see the names of machines, etc. This is for a laptop NIDS.

 

If anyone has relative easy answers for how to use snort (I can't make much sense of the documentation for snort or snortsam), some sort of Captain Obvious information, it would be greatly appreciate. Otherwise, I guess I am just going to avoid coffee shop wifi like I have been. Anyone have thoughts on tripwire?





Reply to this topic



  



Also tagged with one or more of these keywords: upower

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users