Jump to content

Photo

no sound in Asus xonar dx

- - - - -

Best Answer cardinal , 12 August 2017 - 02:15 PM

Please run the alsa information script.

wget http://www.alsa-project.org/alsa-info.sh
chmod +x alsa-info.sh
./alsa-info.sh

Choose y to upload the information.
Provide the link to uploaded info in your reply.

Go to the full post »


2 replies to this topic

#1
adcdam

adcdam

    Advanced Member

  • Members
  • PipPipPip
  • 100 posts

Hi, i can not get Alsa to detect the sound card, the sound card is a Asus xonar dx, in arch linux it work, so is not a hardware problem with the card, i selected in kernel configuration, alsa as built in, c-media oxygen and c media codec,

lspci | grep -i audio
01:00.1 Audio device: NVIDIA Corporation Device 10f1 (rev a1) 
08:04.0 Multimedia audio controller: C-Media Electronics Inc CMI8788 [Oxygen HD Audio]

  aplay -L:

Discard all samples (playback) or generate zero samples (capture) 
hdmi:CARD=NVidia,DEV=0 
    HDA NVidia, HDMI 0 
    HDMI Audio Output 
hdmi:CARD=NVidia,DEV=1 
    HDA NVidia, HDMI 1 
    HDMI Audio Output 
hdmi:CARD=NVidia,DEV=2 
    HDA NVidia, HDMI 2 
    HDMI Audio Output 
hdmi:CARD=NVidia,DEV=3 
    HDA NVidia, HDMI 3 
    HDMI Audio Output

thanks!!



#2
cardinal

cardinal

    Advanced Member

  • Members
  • PipPipPip
  • 242 posts
✓  Best Answer

Please run the alsa information script.

wget http://www.alsa-project.org/alsa-info.sh
chmod +x alsa-info.sh
./alsa-info.sh

Choose y to upload the information.
Provide the link to uploaded info in your reply.



#3
adcdam

adcdam

    Advanced Member

  • Members
  • PipPipPip
  • 100 posts

Thanks Cardinal i solved the problem, there was a asus av66/100/200 option in the kernel menu, i selected that one as module, i recompiled the kernel, rebooted and alsa detected the sound card now.


  • cardinal likes this



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users