Jump to content

Photo

Difficulties installing kde-meta


Best Answer Sandro , 10 August 2017 - 05:28 AM

I had python as "Global USE flag".

then

euse -P python

The trouble seems fixed but i don't know if that is the best solution.

Go to the full post »


3 replies to this topic

#1
Sandro

Sandro

    Advanced Member

  • Members
  • PipPipPip
  • 358 posts
  • LocationSaronno, Via IV Novembre, 23 21047 Italy

Uhm Sorry this timer i'm confused.

 

I want to install kde-meta but i've troubles about some USE ...

ci74771ht ~ # emerge -DNu world kde-meta
Calculating dependencies... done!
 
!!! The ebuild selected to satisfy "net-misc/networkmanager" has unmet requirements.
- net-misc/networkmanager-1.4.4-r1::gnome-kit USE="bluetooth consolekit dhclient gnutls introspection modemmanager ncurses nss ppp resolvconf vala wext wifi -audit -connection-sharing -json -ofono (-selinux) (-systemd) -teamd -test" ABI_X86="32 64 -x32"
 
  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( nss gnutls )
 
  The above constraints are a subset of the following complete expression:
    modemmanager? ( ppp ) vala? ( introspection ) wext? ( wifi ) exactly-one-of ( nss gnutls )
 
(dependency required by "dev-qt/qtnetwork-5.7.1::dev-kit[networkmanager]" [ebuild])
(dependency required by "kde-frameworks/kdeclarative-5.36.0::kde-kit" [ebuild])
(dependency required by "kde-frameworks/kcmutils-5.36.0::kde-kit" [ebuild])
(dependency required by "kde-plasma/kdeplasma-addons-5.10.4::kde-kit" [ebuild])
(dependency required by "kde-plasma/plasma-meta-5.10.4::kde-kit" [ebuild])
(dependency required by "kde-apps/kde-meta-17.04.3::kde-kit" [ebuild])
(dependency required by "kde-meta" [argument])
ci74771ht ~ # euse -D gnutls -p net-misc/networkmanager
Adding "net-misc/networkmanager[-gnutls]" use flag in "/etc/portage/package.use"
ci74771ht ~ # emerge -DNu world kde-meta
Calculating dependencies   * waiting for lock on /var/db/.pkg.portage_lockfile ...                                                                                                                               [ ok ]
... done!
 
The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by media-libs/phonon-4.9.1::media-kit[vlc]
# required by kde-frameworks/khtml-5.36.0::kde-kit
# required by kde-apps/kio-extras-17.04.3::kde-kit[man]
# required by kde-plasma/plasma-workspace-5.10.4-r2::kde-kit
# required by kde-plasma/plasma-meta-5.10.4::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=media-libs/phonon-vlc-0.9.1 qt5
# required by net-libs/glib-networking-2.48.2::gnome-kit[smartcard]
# required by net-libs/libsoup-2.54.1-r1::gnome-kit
# required by media-plugins/gst-plugins-soup-1.10.4::media-kit
# required by media-libs/phonon-gstreamer-4.9.0::media-kit[network]
# required by media-libs/phonon-4.9.1::media-kit[gstreamer]
# required by kde-frameworks/khtml-5.36.0::kde-kit
# required by kde-apps/kio-extras-17.04.3::kde-kit[man]
# required by kde-plasma/plasma-workspace-5.10.4-r2::kde-kit
# required by kde-plasma/plasma-meta-5.10.4::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=net-libs/gnutls-3.5.11 pkcs11
# required by kde-frameworks/kfilemetadata-5.36.0::kde-kit[pdf]
# required by kde-frameworks/baloo-5.36.0::kde-kit
# required by kde-plasma/plasma-workspace-5.10.4-r2::kde-kit[semantic-desktop]
# required by kde-plasma/plasma-meta-5.10.4::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=app-text/poppler-0.52.0 qt5
# required by media-libs/phonon-gstreamer-4.9.0::media-kit
>=media-libs/phonon-4.9.1 qt5
# required by media-libs/phonon-4.9.1::media-kit[gstreamer]
# required by kde-frameworks/khtml-5.36.0::kde-kit
# required by kde-apps/kio-extras-17.04.3::kde-kit[man]
# required by kde-plasma/plasma-workspace-5.10.4-r2::kde-kit
# required by kde-plasma/plasma-meta-5.10.4::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=media-libs/phonon-gstreamer-4.9.0 qt5
# required by dev-qt/qtwayland-5.7.1::dev-kit
# required by kde-frameworks/kwayland-5.36.0::kde-kit
# required by kde-plasma/plasma-integration-5.10.4::kde-kit
# required by kde-plasma/plasma-meta-5.10.4::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-qt/qtgui-5.7.1-r1 egl
# required by dev-qt/qtcore-5.7.1-r3::dev-kit
# required by kde-frameworks/kfilemetadata-5.36.0::kde-kit
# required by kde-frameworks/baloo-5.36.0::kde-kit
# required by kde-plasma/plasma-workspace-5.10.4-r2::kde-kit[semantic-desktop]
# required by kde-plasma/plasma-meta-5.10.4::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-libs/libpcre-8.40-r1 pcre16
# required by kde-frameworks/kwayland-5.36.0::kde-kit
# required by kde-plasma/plasma-integration-5.10.4::kde-kit
# required by kde-plasma/plasma-meta-5.10.4::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-qt/qtwayland-5.7.1 egl
# required by kde-frameworks/knotifications-5.36.0::kde-kit[dbus]
# required by kde-plasma/bluedevil-5.10.4::kde-kit
# required by kde-plasma/plasma-meta-5.10.4::kde-kit[bluetooth]
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-libs/libdbusmenu-qt-0.9.3_pre20160218 qt5
 
Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.
 
!!! The ebuild selected to satisfy ">=dev-qt/qtwebkit-5.7.1:5" has unmet requirements.
- dev-qt/qtwebkit-5.7.1::dev-kit USE="gstreamer jit multimedia opengl webp -debug -geolocation -gstreamer010 -orientation -printsupport -qml -test -webchannel"
 
  The following REQUIRED_USE flag constraints are unsatisfied:
    at-most-one-of ( gstreamer gstreamer010 multimedia )
 
(dependency required by "kde-plasma/libksysguard-5.10.4::kde-kit[detailedmemory]" [ebuild])
(dependency required by "kde-plasma/plasma-meta-5.10.4::kde-kit" [ebuild])
(dependency required by "kde-apps/kde-meta-17.04.3::kde-kit" [ebuild])
(dependency required by "kde-meta" [argument]

So i try the autounmask-write.

 

and i obtain ....

ci74771ht ~ # etc-update 
Scanning Configuration files...
The following is the list of files which need updating, each
configuration file is followed by a list of possible replacement files.
1) /etc/portage/package.use (1)
Please select a file to edit by entering the corresponding number.
              (don't use -3, -5, -7 or -9 if you're unsure what to do)
              (-1 to exit) (-3 to auto merge all files)
                           (-5 to auto-merge AND not use 'mv -i')
                           (-7 to discard all updates)
                           (-9 to discard all updates AND not use 'rm -i'): -5
Replacing /etc/portage/package.use with /etc/portage/._cfg0000_package.use
Exiting: Nothing left to do; exiting. :)
ci74771ht ~ # emerge -DNu world kde-meta
Calculating dependencies... done!
 
!!! The ebuild selected to satisfy ">=dev-qt/qtwebkit-5.7.1:5" has unmet requirements.
- dev-qt/qtwebkit-5.7.1::dev-kit USE="gstreamer jit multimedia opengl webp -debug -geolocation -gstreamer010 -orientation -printsupport -qml -test -webchannel"
 
  The following REQUIRED_USE flag constraints are unsatisfied:
    at-most-one-of ( gstreamer gstreamer010 multimedia )
 
(dependency required by "kde-plasma/libksysguard-5.10.4::kde-kit[detailedmemory]" [ebuild])
(dependency required by "kde-plasma/plasma-meta-5.10.4::kde-kit" [ebuild])
(dependency required by "kde-apps/kde-meta-17.04.3::kde-kit" [ebuild])
(dependency required by "kde-meta" [argument])

So i "prune" multimedia from my Global UISE flags ;

 

next step: ci74771ht ~ # emerge -DNu world kde-meta

Calculating dependencies... done!
 
ci74771ht ~ # emerge -DNu world kde-meta
Calculating dependencies   * waiting for lock on /var/db/.pkg.portage_lockfile ...                                                                                                                               [ ok ]
... done!
 
The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-qt/qtgui-5.7.1-r1::dev-kit[egl]
# required by kde-frameworks/kcompletion-5.36.0::kde-kit
# required by kde-frameworks/ktextwidgets-5.36.0::kde-kit
# required by kde-frameworks/kparts-5.36.0::kde-kit
# required by kde-frameworks/kdelibs4support-5.36.0::kde-kit
# required by kde-plasma/kdeplasma-addons-5.10.4::kde-kit
# required by kde-plasma/plasma-meta-5.10.4::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=media-libs/mesa-13.0.1 wayland
# required by media-libs/phonon-4.9.1::media-kit
# required by media-libs/phonon-gstreamer-4.9.0::media-kit
>=media-sound/pulseaudio-10.0 gnome
# required by media-libs/phonon-gstreamer-4.9.0::media-kit[qt4]
# required by media-libs/phonon-4.9.1::media-kit[gstreamer]
# required by kde-frameworks/knotifications-5.36.0::kde-kit
# required by kde-frameworks/plasma-5.36.0::kde-kit
# required by kde-frameworks/krunner-5.36.0::kde-kit
# required by kde-plasma/kdeplasma-addons-5.10.4::kde-kit
# required by kde-plasma/plasma-meta-5.10.4::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-qt/qtopengl-4.8.7:4 qt3support
# required by dev-qt/qtgui-4.8.7::dev-kit
# required by sys-auth/polkit-qt-0.112.0_p20160416::nokit[qt4]
# required by kde-frameworks/kauth-5.36.0::kde-kit[policykit]
# required by kde-frameworks/kcmutils-5.36.0::kde-kit
# required by kde-plasma/kdeplasma-addons-5.10.4::kde-kit
# required by kde-plasma/plasma-meta-5.10.4::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-qt/qtcore-4.8.7-r2:4 qt3support
# required by dev-qt/qt3support-4.8.7::dev-kit
# required by dev-qt/qtgui-4.8.7::dev-kit[qt3support]
# required by sys-auth/polkit-qt-0.112.0_p20160416::nokit[qt4]
# required by kde-frameworks/kauth-5.36.0::kde-kit[policykit]
# required by kde-frameworks/kcmutils-5.36.0::kde-kit
# required by kde-plasma/kdeplasma-addons-5.10.4::kde-kit
# required by kde-plasma/plasma-meta-5.10.4::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-qt/qtsql-4.8.7-r1:4 qt3support
# required by dev-qt/qtcore-4.8.7-r2::dev-kit[qt3support]
# required by sys-auth/polkit-qt-0.112.0_p20160416::nokit[qt4]
# required by kde-frameworks/kauth-5.36.0::kde-kit[policykit]
# required by kde-frameworks/kcmutils-5.36.0::kde-kit
# required by kde-plasma/kdeplasma-addons-5.10.4::kde-kit
# required by kde-plasma/plasma-meta-5.10.4::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-qt/qtgui-4.8.7:4 qt3support
# required by kde-frameworks/kauth-5.36.0::kde-kit[policykit]
# required by kde-frameworks/kcmutils-5.36.0::kde-kit
# required by kde-plasma/kdeplasma-addons-5.10.4::kde-kit
# required by kde-plasma/plasma-meta-5.10.4::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=sys-auth/polkit-qt-0.112.0_p20160416 qt4
 
Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.
____________________________________
 
next step ... i try to use the --autoumask-write.
 
 
And now the trouble is here:
ci74771ht ~ # emerge -DNu world kde-meta
Calculating dependencies... done!
 
!!! The ebuild selected to satisfy "sys-apps/pcsc-lite" has unmet requirements.
- sys-apps/pcsc-lite-1.8.22::nokit USE="(policykit) python udev -libusb (-selinux)" ABI_X86="32 64 -x32" PYTHON_SINGLE_TARGET="python2_7 python3_4 -python3_5 -python3_6" PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6"
 
  The following REQUIRED_USE flag constraints are unsatisfied:
    python? ( exactly-one-of ( python_single_target_python2_7 python_single_target_python3_4 python_single_target_python3_5 python_single_target_python3_6 ) )
 
  The above constraints are a subset of the following complete expression:
    exactly-one-of ( udev libusb ) python? ( exactly-one-of ( python_single_target_python2_7 python_single_target_python3_4 python_single_target_python3_5 python_single_target_python3_6 ) python_single_target_python2_7? ( python_targets_python2_7 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python3_5? ( python_targets_python3_5 ) python_single_target_python3_6? ( python_targets_python3_6 ) )
 
(dependency required by "net-misc/freerdp-2.0.0_rc0::net-kit[smartcard]" [ebuild])
(dependency required by "kde-apps/krdc-17.04.3::kde-kit[rdp]" [ebuild])
(dependency required by "kde-apps/kdenetwork-meta-17.04.3::kde-kit" [ebuild])
(dependency required by "kde-apps/kde-apps-meta-17.04.3::kde-kit" [ebuild])
(dependency required by "kde-apps/kde-meta-17.04.3::kde-kit" [ebuild])
(dependency required by "kde-meta" [argument])

Last error:

emerge: there are no ebuilds to satisfy "~dev-libs/protobuf-3.3.0".
(dependency required by "dev-java/protobuf-java-3.3.0::java-kit" [ebuild])
(dependency required by "dev-libs/protobuf-3.1.0::core-kit[java]" [ebuild])
(dependency required by "dev-python/protobuf-python-3.1.0::python-kit" [ebuild])
ci74771ht ~ # 
 

.

 

Then i obtain

he following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by app-admin/ego-1.1.2::core-kit
# required by @system
# required by @world (argument)
# /var/git/meta-repo/kits/core-kit/profiles/package.mask/funtoo-python:
# Add mask for ongoing works with python-exec and friends. No trust it tested enough to get bumps.
=dev-lang/python-3.5.3
 
The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-python/zope-interface-4.3.3::python-kit
# required by dev-python/twisted-17.1.0::python-kit
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/setuptools-34.4.1 python_targets_python3_5
# required by dev-python/twisted-17.1.0::python-kit
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/zope-interface-4.3.3 python_targets_python3_5
# required by dev-python/cffi-1.10.0::python-kit
# required by dev-python/cryptography-1.7.2::python-kit[python_targets_python2_7,python_targets_python3_4,python_targets_python3_5,-python_targets_python3_6]
# required by dev-python/pyopenssl-16.2.0::python-kit
# required by dev-python/service_identity-16.0.0::python-kit
# required by dev-python/twisted-17.1.0::python-kit[crypt]
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/pycparser-2.17 python_targets_python3_5
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/twisted-17.1.0 python_targets_python3_5
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/PyQt5-5.8.2 gui python_targets_python3_5
# required by dev-python/setuptools-34.4.1::python-kit
# required by dev-python/protobuf-python-3.1.0::python-kit
# required by dev-libs/protobuf-3.1.0::core-kit[python]
# required by dev-qt/qtwebengine-5.7.1-r2::dev-kit
# required by kde-apps/akonadi-contacts-17.04.3::kde-kit
# required by kde-apps/kgpg-17.04.3::kde-kit
# required by kde-apps/kdeutils-meta-17.04.3::kde-kit
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/certifi-2017.1.23 python_targets_python3_5
# required by dev-python/automat-0.5.0::python-kit
# required by dev-python/twisted-17.1.0::python-kit
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/m2r-0.1.5 python_targets_python3_5
# required by dev-python/m2r-0.1.5::python-kit
# required by dev-python/automat-0.5.0::python-kit
# required by dev-python/twisted-17.1.0::python-kit
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/docutils-0.13.1 python_targets_python3_5
# required by dev-python/setuptools-34.4.1::python-kit
# required by dev-python/protobuf-python-3.1.0::python-kit
# required by dev-libs/protobuf-3.1.0::core-kit[python]
# required by dev-qt/qtwebengine-5.7.1-r2::dev-kit
# required by kde-apps/akonadi-contacts-17.04.3::kde-kit
# required by kde-apps/kgpg-17.04.3::kde-kit
# required by kde-apps/kdeutils-meta-17.04.3::kde-kit
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/six-1.10.0 python_targets_python3_5
# required by dev-python/automat-0.5.0::python-kit
# required by dev-python/twisted-17.1.0::python-kit
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/attrs-16.3.0-r1 python_targets_python3_5
# required by dev-python/twisted-17.1.0::python-kit[crypt]
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/service_identity-16.0.0 python_targets_python3_5
# required by dev-python/twisted-17.1.0::python-kit
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/automat-0.5.0 python_targets_python3_5
# required by dev-python/pycparser-2.17::python-kit
# required by dev-python/cffi-1.10.0::python-kit
# required by dev-python/cryptography-1.7.2::python-kit[python_targets_python2_7,python_targets_python3_4,python_targets_python3_5,-python_targets_python3_6]
# required by dev-python/pyopenssl-16.2.0::python-kit
# required by dev-python/service_identity-16.0.0::python-kit
# required by dev-python/twisted-17.1.0::python-kit[crypt]
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/ply-3.10 python_targets_python3_5
# required by dev-python/docutils-0.13.1::python-kit
# required by x11-misc/sddm-0.14.0-r3::desktop-kit
# required by kde-plasma/plasma-meta-5.10.4::kde-kit[sddm,display-manager]
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/pygments-2.2.0 python_targets_python3_5
# required by dev-python/twisted-17.1.0::python-kit
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/constantly-15.1.0 python_targets_python3_5
# required by dev-python/cryptography-1.7.2::python-kit[python_targets_python2_7,python_targets_python3_4,python_targets_python3_5,-python_targets_python3_6]
# required by dev-python/pyopenssl-16.2.0::python-kit
# required by dev-python/service_identity-16.0.0::python-kit
# required by dev-python/twisted-17.1.0::python-kit[crypt]
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/cffi-1.10.0 python_targets_python3_5
# required by dev-python/service_identity-16.0.0::python-kit
# required by dev-python/twisted-17.1.0::python-kit[crypt]
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/pyasn1-modules-0.0.8 python_targets_python3_5
# required by dev-python/cryptography-1.7.2::python-kit
# required by dev-python/pyopenssl-16.2.0::python-kit
# required by dev-python/service_identity-16.0.0::python-kit
# required by dev-python/twisted-17.1.0::python-kit[crypt]
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/idna-2.5 python_targets_python3_5
# required by dev-python/PyQt5-5.8.2::python-kit[dbus]
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/dbus-python-1.2.4 python_targets_python3_5
# required by dev-python/setuptools-34.4.1::python-kit
# required by dev-python/protobuf-python-3.1.0::python-kit
# required by dev-libs/protobuf-3.1.0::core-kit[python]
# required by dev-qt/qtwebengine-5.7.1-r2::dev-kit
# required by kde-apps/akonadi-contacts-17.04.3::kde-kit
# required by kde-apps/kgpg-17.04.3::kde-kit
# required by kde-apps/kdeutils-meta-17.04.3::kde-kit
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/appdirs-1.4.3 python_targets_python3_5
# required by dev-python/pyopenssl-16.2.0::python-kit
# required by dev-python/service_identity-16.0.0::python-kit
# required by dev-python/twisted-17.1.0::python-kit[crypt]
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/cryptography-1.7.2 python_targets_python3_5
# required by dev-python/mistune-0.7.2::python-kit
# required by dev-python/m2r-0.1.5::python-kit
# required by dev-python/automat-0.5.0::python-kit
# required by dev-python/twisted-17.1.0::python-kit
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/cython-0.25.2 python_targets_python3_5
# required by dev-python/twisted-17.1.0::python-kit[crypt]
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/pyopenssl-16.2.0 python_targets_python3_5
# required by dev-python/twisted-17.1.0::python-kit
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/incremental-16.10.1 python_targets_python3_5
# required by dev-python/packaging-16.8::python-kit
# required by dev-python/setuptools-34.4.1::python-kit
# required by dev-python/protobuf-python-3.1.0::python-kit
# required by dev-libs/protobuf-3.1.0::core-kit[python]
# required by dev-qt/qtwebengine-5.7.1-r2::dev-kit
# required by kde-apps/akonadi-contacts-17.04.3::kde-kit
# required by kde-apps/kgpg-17.04.3::kde-kit
# required by kde-apps/kdeutils-meta-17.04.3::kde-kit
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/pyparsing-2.1.10 python_targets_python3_5
# required by dev-python/PyQt5-5.8.2::python-kit
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/sip-4.19.2 python_targets_python3_5
# required by dev-python/pyasn1-modules-0.0.8::python-kit
# required by dev-python/service_identity-16.0.0::python-kit
# required by dev-python/twisted-17.1.0::python-kit[crypt]
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/pyasn1-0.2.3 python_targets_python3_5
# required by dev-python/m2r-0.1.5::python-kit
# required by dev-python/automat-0.5.0::python-kit
# required by dev-python/twisted-17.1.0::python-kit
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/mistune-0.7.2 python_targets_python3_5
# required by dev-python/cryptography-1.7.2::python-kit
# required by dev-python/pyopenssl-16.2.0::python-kit
# required by dev-python/service_identity-16.0.0::python-kit
# required by dev-python/twisted-17.1.0::python-kit[crypt]
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=virtual/python-ipaddress-1.0-r1 python_targets_python3_5
# required by dev-python/automat-0.5.0::python-kit
# required by dev-python/twisted-17.1.0::python-kit
# required by kde-apps/kajongg-17.04.3::kde-kit
# required by kde-apps/kdegames-meta-17.04.3::kde-kit[python]
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/setuptools_scm-1.15.5 python_targets_python3_5
# required by dev-python/setuptools-34.4.1::python-kit
# required by dev-python/protobuf-python-3.1.0::python-kit
# required by dev-libs/protobuf-3.1.0::core-kit[python]
# required by dev-qt/qtwebengine-5.7.1-r2::dev-kit
# required by kde-apps/akonadi-contacts-17.04.3::kde-kit
# required by kde-apps/kgpg-17.04.3::kde-kit
# required by kde-apps/kdeutils-meta-17.04.3::kde-kit
# required by kde-apps/kde-apps-meta-17.04.3::kde-kit
# required by kde-apps/kde-meta-17.04.3::kde-kit
# required by kde-meta (argument)
>=dev-python/packaging-16.8 python_targets_python3_5
 
NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.
 
Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

Then i don't know how to operate without installing python3_5

 

Excuse me for my ignoarnce :|



#2
cafaia

cafaia

    Advanced Member

  • Members
  • PipPipPip
  • 38 posts

Hello, Sandro!

 

Did you try this:

 

kde-apps/kdegames-meta -python

 

in /etc/portage/package.use ?

 

It is very good to know you're back!

 

With best regards!



#3
Oleg Vinichenko

Oleg Vinichenko

    Staff

  • Moderators
  • 380 posts

appears that you are not using kde-plasma-5 mix-in enabled. it has this python sorted.


www.funtoo.org

#4
Sandro

Sandro

    Advanced Member

  • Members
  • PipPipPip
  • 358 posts
  • LocationSaronno, Via IV Novembre, 23 21047 Italy
✓  Best Answer

I had python as "Global USE flag".

then

euse -P python

The trouble seems fixed but i don't know if that is the best solution.





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users