Jump to content

Photo

I cannot get Dunst and libnotify to work

- - - - -

17 replies to this topic

#1
Hund

Hund

    Newbie

  • Members
  • Pip
  • 6 posts
  • LocationSweden

I installed Funtoo (using the "pure64" and "workstation" profile) a few days ago and it works great - except for no notifications.

 

I have used Dunst and libnotify in the past with both Arch and Gentoo without any issues. But for some reason it do not want to work in Funtoo.

$ dunst
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  139 (RANDR)
  Minor opcode of failed request:  42 ()
  Serial number of failed request:  42
  Current serial number in output stream:  42
The command "notify-send" shows nothing, no notification or any error message. I'm not sure how to debug this any further? Help? :)


#2
Hund

Hund

    Newbie

  • Members
  • Pip
  • 6 posts
  • LocationSweden
This happens in dbus when I run "$ notify-send Hund" : https://pastebin.com/bjasAhNX
 
Edit: With "$ dunstify Hund" I get: 
 
Unable to send notification: Error calling StartServiceByName for org.freedesktop.Notifications: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.Notifications exited with status 1


#3
Hund

Hund

    Newbie

  • Members
  • Pip
  • 6 posts
  • LocationSweden

I noticed this message when I closed X:
 

XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
after 314 requests (314 known processed) with 0 events remaining.


#4
onli

onli

    Member

  • Members
  • PipPip
  • 16 posts

Hey, not sure about this at all, but this might be a dbus error. Is dbus working in general? If you are using a Window Manager, are you wrapping its launch script with dbus-launch?

 

I'm using dunst on my Funtoo desktop, so in general it can work.

 

Edit: Seeing your log only know it seems like dbus is indeed running and I'm on the wrong track.


  • Hund likes this

#5
Hund

Hund

    Newbie

  • Members
  • Pip
  • 6 posts
  • LocationSweden

After much help via IRC from several friendly users I managed to (finally) solve it.

 

I had by accident installed two notifications server (from all the testing), which resultet in that none of them worked. And the reason that Dunst didn't work, was that it needed the version 1.5 of RanR and I had only version 1.4.

 

And now it finally works! :D


  • onli likes this

#6
agaric

agaric

    Newbie

  • Members
  • Pip
  • 2 posts

I'm getting the same BadRequest X Error as Hund, but I only have one notification server installed (dunst), plus libnotify 0.7.6-r3 and xrandr 1.5.0.

 

This started happening after I switched to kits whilst keeping my profile the same ("desktop" flavor, "current" build)

 

Has anyone else come across this?

 

edit: @onli , my dunst used to work as well, before I switched to kits. So I'm wondering, have you made the switch as well?



#7
onli

onli

    Member

  • Members
  • PipPip
  • 16 posts

edit: @onli , my dunst used to work as well, before I switched to kits. So I'm wondering, have you made the switch as well?

 

No, I wasn't aware of that and changed nothing.



#8
checkulater

checkulater

    Newbie

  • Members
  • Pip
  • 5 posts

I can confirm I'm having the same problem. agaric have you managed to solve it?



#9
checkulater

checkulater

    Newbie

  • Members
  • Pip
  • 5 posts

I found a temporary solution. Need to downgrade the version to 1.1.0 do this by using the commands

 

emerge -C dunst

emerge =x11-misc/dunst-1.1.0

 

If you dont want it upgraded you need to add =x11-misc/dunst-1.2.0 to /etc/portage/package.mask



#10
Oleg Vinichenko

Oleg Vinichenko

    Staff

  • Moderators
  • 410 posts

it was found that updating to libXrandr was the fix, it's in topic best answer.


www.funtoo.org

#11
checkulater

checkulater

    Newbie

  • Members
  • Pip
  • 5 posts

sorry to to say oleg it did not work updating libXrandr. I tested dunst 1.2.0 running libXrandr 1.5.1. And still got the same error.



#12
Oleg Vinichenko

Oleg Vinichenko

    Staff

  • Moderators
  • 410 posts

then, something else fixed the dunst for a topic starter


www.funtoo.org

#13
checkulater

checkulater

    Newbie

  • Members
  • Pip
  • 5 posts

so i have been experimenting some more. Checked dunst changelog which says "Dropped Xinerama in favour of RandR, Xinerama can be enabled with the -force_xinerama option if needed". In the config file there is an option that says force_xinerama = false. Change it to true. If you dont have that option, it means that you are using the config file of dunst 1.1.0 still. You should update it because they have changed some other things to. You can copy it from /usr/share/dunst/dunstrc and put it in ~/.config/dunst/dunstrc

 

dont know why i cant use randr



#14
Hund

Hund

    Newbie

  • Members
  • Pip
  • 6 posts
  • LocationSweden

I downgraded Xorg from version 1.19 to 1.17 today (due to unrelated issues) and Dunst 1.2.0 stopped working for me, but downgrading to version 1.1.0 solved it.



#15
checkulater

checkulater

    Newbie

  • Members
  • Pip
  • 5 posts

hund if you want to use version 1.2.0 of dunst read my previous comment and copy the config file from "/usr/share/dunst/dunstrc" and put it in "~/.config/dunst/dunstrc" then change the "force_xinerama = false" setting to "force_xinerama = true"


  • onli and Hund like this

#16
Hund

Hund

    Newbie

  • Members
  • Pip
  • 6 posts
  • LocationSweden

hund if you want to use version 1.2.0 of dunst read my previous comment and copy the config file from "/usr/share/dunst/dunstrc" and put it in "~/.config/dunst/dunstrc" then change the "force_xinerama = false" setting to "force_xinerama = true"


Oh, I totally missed that. Thank you!

#17
agaric

agaric

    Newbie

  • Members
  • Pip
  • 2 posts

agaric have you managed to solve it?

 

@checkulater Sorry for the late reply. I was continuing without dunst until your recommendation (setting force_xinerama to true) fixed it for me. Thank you very much.

 
"dunst will not be able to detect when a montitor is connected or disconnected" (according to /usr/share/dunst/dunstrc) sounds less than ideal, but at least the daemon runs. I can't tell whether the xrandr incompatibility is an upstream issue or an ebuild-related one. I haven't been able to find any related issues on https://github.com/dunst-project/dunst either.


#18
onli

onli

    Member

  • Members
  • PipPip
  • 16 posts

Same for me, btw. Problem began when moving to the kits, setting force_xinerama = true made it work again.





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users