Jump to content

Photo

Mutt asks me to accept certificate

- - - - -

Best Answer hick518 , 23 February 2017 - 01:12 AM

Installing mutt 1.7.2-r2 fixed my problem.  That version required a change in USE flags.  It was also masked on my stable system.

 

/etc/portage/package.use:

mail-client/mutt -berkdb -tokyocabinet

/etc/portage/package.accept_keywords:

=mail-client/mutt-1.7.2-r2 ~amd64

I'm not sure where the problem crept in, but now I'm back in business.  Thanks for the help, Cardinal.

Go to the full post »


5 replies to this topic

#1
hick518

hick518

    Advanced Member

  • Members
  • PipPipPip
  • 37 posts

Sometime around the beginning of this year, Mutt (my email client) started asking me to accept a certificate when I try to access my gmail account.  I have not accepted it yet and have instead been using gmail's web interface.  But that's pretty annoying and I want to get Mutt working again.

 

I've tested on a Devuan system and it works normally (like my Funtoo system did until a couple months ago).  I'm not sure if it's a bug or a problem with my configuration (which I don't think has changed).

 

Could somebody test their Funtoo system and let me know what you find?

 

1)  Start Mutt:

mutt

 

2)  Connect to a mailbox:

c

 

3)  Enter the details:

imaps://imap.gmail.com:993

 

On a working system, you should get prompted for a username.  But on my broken system, I get the following, at which point I hit Ctrl-C to stop (neither accepting or rejecting the certificate).  Any testing or insight into my problem would be appreciated.

 

This certificate belongs to:
   GeoTrust Global CA
   Unknown
   GeoTrust Inc.
   Unknown
   Unknown

This certificate was issued by:
   Unknown
   Unknown
   Equifax
   Equifax Secure Certificate Authority
   Unknown

This certificate is valid
   from May 21 04:00:00 2002 GMT
     to Aug 21 04:00:00 2018 GMT

Fingerprint: 2E7D B2A3 1D0E 3DA4 B25F 49B9 542A 2E1A



#2
cardinal

cardinal

    Advanced Member

  • Members
  • PipPipPip
  • 233 posts

When I removed ca-certificates from my system I received the same prompt from mutt.

I used the a key to (a)ccept always and was logged in immediately.

This stores the certificate at ~/.mutt_certificates

Using the o key for accept (o)nce failed and I wasn't logged in.

The best solution is to emerge ca-certificates on your system,the certificates will always be valid, up-to-date, and available to all users.

 

Mutt gmail imap login works for me with these Google My Account settings:
Allow less secure apps with 2-factor disabled:
Sign-in and security settings/password and sign-in method/2-Step Verification: turn off
Connected apps and sites: Allow less secure apps: on
Generate and use app password for mutt with 2-factor enabled:
Sign-in and security settings/password and sign-in method/2-Step Verification: turn on
Sign-in and security settings/password and sign-in method/App passwords/Generate mutt password
 
[i] mail-client/mutt
     Available versions:  *1.5.23-r7 1.5.24-r2 (~)1.7.2 (~)1.7.2-r1 (~)1.7.2-r2 {berkdb crypt debug doc gdbm gnutls gpg +hcache idn imap kerberos libressl lmdb mbox nls nntp notmuch pop qdbm sasl selinux sidebar slang smime smtp ssl tokyocabinet vanilla}
     Installed versions:  1.7.2-r2(05:37:33 PM 02/13/2017)(crypt gdbm hcache imap mbox nls sasl smtp ssl -berkdb -debug -doc -gnutls -gpg -idn -kerberos -libressl -lmdb -nntp -notmuch -pop -qdbm -selinux -sidebar -slang -smime -tokyocabinet -vanilla)
     Homepage:            http://www.mutt.org/
     Description:         A small but very powerful text-based mail client



#3
hick518

hick518

    Advanced Member

  • Members
  • PipPipPip
  • 37 posts

Cardinal, I checked my Google My Account settings and they match yours.  I tried running Mutt as a different user on the same system and I get the same behavior (it asks me to accept or reject a certificate). 

 

What command did you run to get the mutt info at the bottom of your post?  I tried 'emerge -pv mutt' but that output is slightly different.



#4
cardinal

cardinal

    Advanced Member

  • Members
  • PipPipPip
  • 233 posts
 eix mail-client/mutt

If your accepting the certificate, have the same use flags enabled as I do, and it still refuses to connect you may have a problem with ~/.muttrc

Build mutt with +debug use flag, start with mutt -d 3 and try to connect.

Quit mutt and check ~/.muttdebug0 for errors. 



#5
hick518

hick518

    Advanced Member

  • Members
  • PipPipPip
  • 37 posts

I see you've got a different version installed than I do. 

 

Just to be clear, the problem is not that mutt fails to connect.  It's that it's presenting me with a certificate that I do not recognize and it never did this before.  In fact, one time I chose to reject the certificate and it connected me to gmail anyway.  But still it asks me to accept or reject the certificate each time I run mutt. 

 

I won't have much time for this until next week, but I'll post back any findings.  Thanks for your help, Cardinal.

 

[I] mail-client/mutt
     Available versions:  *1.5.23-r7 1.5.24-r2{tbz2} ~1.7.2 ~1.7.2-r1 ~1.7.2-r2 {berkdb crypt debug doc gdbm gnutls gpg +hcache idn imap kerberos libressl lmdb mbox nls nntp notmuch pop qdbm sasl selinux sidebar slang smime smtp ssl tokyocabinet vanilla}
     Installed versions:  1.5.24-r2{tbz2}(05:15:14 PM 01/31/2017)(berkdb crypt gdbm gpg imap mbox nls sasl smtp ssl tokyocabinet -debug -doc -gnutls -idn -kerberos -libressl -nntp -pop -qdbm -selinux -sidebar -slang -smime)
     Homepage:            http://www.mutt.org/
     Description:         A small but very powerful text-based mail client
 



#6
hick518

hick518

    Advanced Member

  • Members
  • PipPipPip
  • 37 posts
✓  Best Answer

Installing mutt 1.7.2-r2 fixed my problem.  That version required a change in USE flags.  It was also masked on my stable system.

 

/etc/portage/package.use:

mail-client/mutt -berkdb -tokyocabinet

/etc/portage/package.accept_keywords:

=mail-client/mutt-1.7.2-r2 ~amd64

I'm not sure where the problem crept in, but now I'm back in business.  Thanks for the help, Cardinal.





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users