Jump to content

Photo

Errors in eix-sync!

- - - - - eix portage cache

6 replies to this topic

#1
cafaia

cafaia

    Member

  • Members
  • PipPip
  • 21 posts

When I do "eix-sync", I have:

 

[0] "local" /usr/local/portage/ (cache: metadata-md5-or-flat)
     Reading category 170|170 (100) EMPTY!
 
But I have ebuilds in local overlay and "OVERLAY_CACHE_METHOD="assign"" in file "/etc/eixrc/01-cache".
 
My file "/etc/eix-sync.conf" have:
 
*
@emerge --regen || true
@emerge --metadata || true

 

Other error: if I do "eix gnome-subtitles" I have:

 

* media-video/gnome-subtitles [1]
     Available versions:  1.3-r1
     Homepage:            http://gnome-subtitl...ourceforge.net/
     Description:         Video subtitling for the Gnome desktop
 
[1] "gentoo" /usr/portage
 
The "eix" command classify the gentoo portage as overlay.
What to do?
Thanks!


#2
cafaia

cafaia

    Member

  • Members
  • PipPip
  • 21 posts

And when I do "eix-update --print PORTDIR_OVERLAY" I have:

 

/var/lib/layman/deadbeef-overlay
/var/lib/layman/eva
/usr/portage
/var/lib/layman/gentoo-zh
/var/lib/layman/torbrowser
 
The value "/usr/portage" should not be listed and the value "/usr/local/portage" is not listed, but should.


#3
cardinal

cardinal

    Advanced Member

  • Members
  • PipPipPip
  • 226 posts
Install wgetpaste on your system.
emerge --info -vv | wgetpaste
Post the link to the paste in your reply.

#4
cafaia

cafaia

    Member

  • Members
  • PipPip
  • 21 posts

Hello, cardinal!

 

The command "emerge --info -vv | wgetpaste" it's here:

 

https://paste.pound-...Ns2w8XtYzwze8F/

 

Thank you!



#5
cardinal

cardinal

    Advanced Member

  • Members
  • PipPipPip
  • 226 posts

I'm not sure where default PORTDIR_OVERLAY is set.

If you have it set in /etc/portage/make.conf comment it out.

I have no PORTDIR_OVERLAY setting in my /etc/portage/make.conf

I have rj local overlay (manual configuration) and deadbeef-overlay (layman)

funtoo rj # cat /etc/portage/repos.conf/*
[DEFAULT]
main-repo = gentoo

[gentoo]
location = /usr/portage
sync-type = git
sync-uri = git://github.com/funtoo/ports-2012.git
auto-sync = yes
[deadbeef-overlay]
priority = 50
location = /var/lib/layman/deadbeef-overlay
layman-type = git
auto-sync = No

[rj]
location = /usr/local/portage
masters = gentoo
auto-sync = no

 

funtoo rj # eix-update --print PORTDIR_OVERLAY
/var/lib/layman/deadbeef-overlay
/usr/local/portage

 

funtoo rj # eix-update --print PORTDIR
/usr/portage/




 



#6
cafaia

cafaia

    Member

  • Members
  • PipPip
  • 21 posts

I too have no PORTDIR_OVERLAY settings in my /etc/portage/make.conf

 

# cat /etc/portage/repos.conf/*

 

[DEFAULT]
main-repo = gentoo
 
[gentoo]
location = /usr/portage
sync-type = git
sync-uri = git://github.com/funtoo/ports-2012.git
auto-sync = yes
[torbrowser]
priority = 50
location = /var/lib/layman/torbrowser
layman-type = git
auto-sync = No
 
[deadbeef-overlay]
priority = 50
location = /var/lib/layman/deadbeef-overlay
layman-type = git
auto-sync = No
 
[eva]
priority = 50
location = /var/lib/layman/eva
layman-type = git
auto-sync = No
 
[gentoo-zh]
priority = 50
location = /var/lib/layman/gentoo-zh
layman-type = git
auto-sync = No
 
[local]
location = /usr/local/portage
master = gentoo
auto-sync = No
priority = 15

 

And my local overlay is too manual configuration.

 

# eix-update --print PORTDIR_OVERLAY

 

/var/lib/layman/deadbeef-overlay
/var/lib/layman/eva
/usr/portage
/var/lib/layman/gentoo-zh
/var/lib/layman/torbrowser
 
# eix-update --print PORTDIR
 
/usr/local/portage/
 
The error is in program "eix", it is defining 'PORTDIR' as '/usr/local/portage' and not as '/usr/portage'.
 
When I do 'portageq envvar PORTDIR_OVERLAY' I have:
 
/usr/local/portage /var/lib/layman/deadbeef-overlay /var/lib/layman/eva /var/lib/layman/gentoo-zh /var/lib/layman/torbrowser
 
And when I do 'portageq envvar PORTDIR' I have:
 
/usr/portage
 
How to change this variable "PORTDIR" and "PORTDIR_OVERLAY" in program "eix"?


#7
cafaia

cafaia

    Member

  • Members
  • PipPip
  • 21 posts

I'm sorry for the error, but I did the value "export PORTDIR="/usr/local/portage"" in file "/etc/bash/bashrc.d/euses".

Thank you all for the help!





Reply to this topic



  



Also tagged with one or more of these keywords: eix, portage, cache

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users