Jump to content

Photo

[Solved] Gnome current sys-devel-llvm error


2 replies to this topic

#1
morphmex

morphmex

    Advanced Member

  • Members
  • PipPipPip
  • 46 posts
  • LocationLivorno- Italy
ROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS -Iutils/TableGen
-I/var/tmp/portage/sys-devel/llvm-3.8.1-r2/work/llvm-3.8.1.src/utils/TableGen
-Iinclude -I/var/tmp/portage/sys-devel/llvm-3.8.1-r2/work/llvm-3.8.1.src/include
 -DNDEBUG -march=core2 -O2 -pipe  -fPIC -fvisibility-inlines-hidden
-Wall -W -Wno-unused-parameter -Wwrite-strings -Wcast-qual
-Wno-missing-field-initializers -pedantic -Wno-long-long
-Wno-maybe-uninitialized -Wdelete-non-virtual-dtor -Wno-comment
-Werror=date-time -std=c++11 -ffunction-sections -fdata-sections -MD
-MT utils/TableGen/CMakeFiles/obj.llvm-tblgen.dir/AsmMatcherEmitter.cpp.o
-MF utils/TableGen/CMakeFiles/obj.llvm-tblgen.dir/AsmMatcherEmitter.cpp.o.d
-o utils/TableGen/CMakeFiles/obj.llvm-tblgen.dir/AsmMatcherEmitter.cpp.o
-c /var/tmp/portage/sys-devel/llvm-3.8.1-r2/work/llvm-3.8.1.src/utils/TableGen/AsmMatcherEmitter.cpp
ninja: build stopped: subcommand failed.
 * ERROR: sys-devel/llvm-3.8.1-r2::gentoo failed (compile phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  115:  Called src_compile
 *   environment, line 4975:  Called multilib-minimal_src_compile
 *   environment, line 3073:  Called multilib_foreach_abi
'multilib-minimal_abi_src_compile'
 *   environment, line 3304:  Called multibuild_foreach_variant
'_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_compile'
 *   environment, line 3008:  Called _multibuild_run
'_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_compile'
 *   environment, line 3006:  Called _multilib_multibuild_wrapper
'multilib-minimal_abi_src_compile'
 *   environment, line  620:  Called multilib-minimal_abi_src_compile
 *   environment, line 3067:  Called multilib_src_compile
 *   environment, line 3516:  Called cmake-utils_src_compile
 *   environment, line 1191:  Called _cmake_execute_optionally 'src_compile'
 *   environment, line  347:  Called enable_cmake-utils_src_compile
 *   environment, line 1491:  Called cmake-utils_src_make
 *   environment, line 1206:  Called _cmake_ninja_src_make
 *   environment, line  403:  Called die
 * The specific snippet of code:
 *       "$@" || die
 *
 * If you need support, post the output of `emerge --info
'=sys-devel/llvm-3.8.1-r2::gentoo'`,
 * the complete build log and the output of `emerge -pqv
'=sys-devel/llvm-3.8.1-r2::gentoo'`.
 * The complete build log is located at
'/var/tmp/portage/sys-devel/llvm-3.8.1-r2/temp/build.log'.
 * The ebuild environment file is located at
'/var/tmp/portage/sys-devel/llvm-3.8.1-r2/temp/environment'.
 * Working directory:
'/var/tmp/portage/sys-devel/llvm-3.8.1-r2/work/llvm-3.8.1.src-abi_x86_32.x86'
 * S: '/var/tmp/portage/sys-devel/llvm-3.8.1-r2/work/llvm-3.8.1.src'

>>> Failed to emerge sys-devel/llvm-3.8.1-r2, Log file:

>>>  '/var/tmp/portage/sys-devel/llvm-3.8.1-r2/temp/build.log'

 * Messages for package sys-devel/llvm-3.8.1-r2:

 * ERROR: sys-devel/llvm-3.8.1-r2::gentoo failed (compile phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  115:  Called src_compile
 *   environment, line 4975:  Called multilib-minimal_src_compile
 *   environment, line 3073:  Called multilib_foreach_abi
'multilib-minimal_abi_src_compile'
 *   environment, line 3304:  Called multibuild_foreach_variant
'_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_compile'
 *   environment, line 3008:  Called _multibuild_run
'_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_compile'
 *   environment, line 3006:  Called _multilib_multibuild_wrapper
'multilib-minimal_abi_src_compile'
 *   environment, line  620:  Called multilib-minimal_abi_src_compile
 *   environment, line 3067:  Called multilib_src_compile
 *   environment, line 3516:  Called cmake-utils_src_compile
 *   environment, line 1191:  Called _cmake_execute_optionally 'src_compile'
 *   environment, line  347:  Called enable_cmake-utils_src_compile
 *   environment, line 1491:  Called cmake-utils_src_make
 *   environment, line 1206:  Called _cmake_ninja_src_make
 *   environment, line  403:  Called die
 * The specific snippet of code:
 *       "$@" || die
 *
 * If you need support, post the output of `emerge --info
'=sys-devel/llvm-3.8.1-r2::gentoo'`,
 * the complete build log and the output of `emerge -pqv
'=sys-devel/llvm-3.8.1-r2::gentoo'`.
 * The complete build log is located at
'/var/tmp/portage/sys-devel/llvm-3.8.1-r2/temp/build.log'.
 * The ebuild environment file is located at
'/var/tmp/portage/sys-devel/llvm-3.8.1-r2/temp/environment'.
 * Working directory:
'/var/tmp/portage/sys-devel/llvm-3.8.1-r2/work/llvm-3.8.1.src-abi_x86_32.x86'
 * S: '/var/tmp/portage/sys-devel/llvm-3.8.1-r2/work/llvm-3.8.1.src'
(chroot) sysresccd / #

Many thanks for your help. ;-)



#2
Oleg Vinichenko

Oleg Vinichenko

    Staff

  • Moderators
  • 365 posts

this snippet is not enough to understand. paste full build.log


www.funtoo.org

#3
morphmex

morphmex

    Advanced Member

  • Members
  • PipPipPip
  • 46 posts
  • LocationLivorno- Italy

Solved with a new emerge --sync ,,,. I think. Now emerge -Dnua @world ok, emerge xorg-x11 (nvidia-drivers) ok, emerge gnome (401 packages) stop samba. It emerge --skipfirst now missing 161 packages. I go ahead.





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users