Jump to content

Photo

Samba-4.1.9 Compile Issue (SOLVED)

- - - - -

6 replies to this topic

#1
eusanpe

eusanpe

    Newbie

  • Members
  • Pip
  • 8 posts

Hello all,

 

Has anyone had issues compiling Samba-4.1.9? I am getting an error saying:

Checking for system subunit                                                                     : not found 
ERROR: System library subunit of version 0.0.0 not found, and bundling disabled
 * ERROR: net-fs/samba-4.1.9 failed (configure phase):
 *   configure failed
 * 
 * Call stack:
 *     ebuild.sh, line   93:  Called src_configure
 *   environment, line 4104:  Called waf-utils_src_configure '--enable-fhs' '--sysconfdir=/etc' '--localstatedir=/var' '--with-modulesdir=/usr/lib64/samba' '--with-pammodulesdir=/lib64/security' '--with-piddir=/var/run/samba' '--disable-rpath' '--disable-rpath-install' '--nopyc' '--nopyo' '--bundled-libraries=NONE' '--builtin-libraries=NONE' '--with-dnsupdate' '--with-acl-support' '--with-ads' '--with-aio-support' '--disable-avahi' '--without-cluster-support' '--enable-cups' '--without-dmapi' '--with-fam' '--disable-gnutls' '--enable-iprint' '--with-ldap' '--with-pam' '--with-pam_smbpass' '--with-quotas' '--with-syslog' '--with-winbind' '--with-shared-modules=idmap_ad'
 *   environment, line 4978:  Called die
 * The specific snippet of code:
 *           CCFLAGS="${CFLAGS}" LINKFLAGS="${CFLAGS} ${LDFLAGS}" "${WAF_BINARY}" "--prefix=${EPREFIX}/usr" "${libdir}" "$@" configure || die "configure failed";
 * 
 * If you need support, post the output of `emerge --info '=net-fs/samba-4.1.9'`,
 * the complete build log and the output of `emerge -pqv '=net-fs/samba-4.1.9'`.
 * The complete build log is located at '/var/tmp/portage/net-fs/samba-4.1.9/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-fs/samba-4.1.9/temp/environment'.
 * Working directory: '/var/tmp/portage/net-fs/samba-4.1.9/work/samba-4.1.9'
 * S: '/var/tmp/portage/net-fs/samba-4.1.9/work/samba-4.1.9'

I removed dev-python/subunit-0.0.18-r1000 and reinstalled it but to no avail.

 

Here are some settings:

 

emerge --info

Portage 2.3.6-r8 (funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-4.8.2, glibc-2.18-r1, 3.14.5-gentoo x86_64)
=================================================================
System uname: Linux-3.14.5-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_E5-2630_0_@_2.30GHz-with-gentoo-2.2.0
KiB Mem:     4043272 total,   2763064 free
KiB Swap:    4194300 total,   4194300 free
Timestamp of tree: Unknown
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45-r1
dev-lang/python:          2.7.8-r1000, 3.3.5-r1000
dev-util/cmake:           2.8.12.2-r1
sys-apps/baselayout:      2.2.0-r6
sys-apps/openrc:          0.12.3-r3
sys-apps/sandbox:         2.6-r2
sys-devel/autoconf:       2.69
sys-devel/automake:       1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.8.2-r2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.18-r1
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="git://github.com/funtoo/ports-2012.git"
SYNC_USER="root"
USE="acl amd64 berkdb bzip2 cracklib crypt cxx dbus gdbm geoip iconv icu mmx modules mudflap multilib ncurses nls nptl openmp pam pcre python readline resolvconf spell sse sse2 ssl tcpd unicode urandom xml zlib" ABI_X86="64" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authn_core authz_core socache_shmcb unixd" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_ABIS="2.7 3.3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby19 ruby20 ruby21" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC_UMASK

I was able to run the configure script from the source code and it worked fine. The configure script running from the ebuild is the issue.

 

Thanks,

Tony

 

 

UPDATE - 11:53 PM CST

 

I noticed that Samba-4.1.6 compiled just fine but Samba-4.1.9 didn't. I ran a diff of the two ebuilds and found the difference.

 

Samba-4.1.6.ebuild portion - (This compiles fine)

src_configure() {
        local myconf=''
        use "cluster" && myconf+=" --with-ctdb-dir=/usr"
        use "test" && myconf+=" --enable-selftest"
        myconf="${myconf} \
                --enable-fhs \
                --sysconfdir=/etc \
                --localstatedir=/var \
                --with-modulesdir=/usr/$(get_libdir)/samba \
                --with-pammodulesdir=/$(get_libdir)/security \
                --with-piddir=/var/run/${PN} \
                --disable-rpath \
                --disable-rpath-install \
                --nopyc \
                --nopyo \
                --bundled-libraries=ntdb \
                --builtin-libraries=ntdb \
                $(use_with addns dnsupdate) \
                $(use_with acl acl-support) \
                $(use_with ads) \
                $(use_with aio aio-support) \
                $(use_enable avahi) \
                $(use_with cluster cluster-support) \
                $(use_enable cups) \
                $(use_with dmapi) \
                $(use_with fam) \
                $(use_enable gnutls) \
                $(use_enable iprint) \
                $(use_with ldap) \
                --with-pam \
                --with-pam_smbpass \
                $(use_with quota quotas) \
                $(use_with syslog) \
                $(use_with winbind)
                "
        use "ads" && myconf+=" --with-shared-modules=idmap_ad"

You will notice that the configure options --bundled-libraries and --builtin-libraries are set to 'ntdb'

 

Samba-4.1.9.ebuild portion - (This does not compile)

src_configure() {
        local myconf=''
        use "cluster" && myconf+=" --with-ctdb-dir=/usr"
        use "test" && myconf+=" --enable-selftest"
        myconf="${myconf} \
                --enable-fhs \
                --sysconfdir=/etc \
                --localstatedir=/var \
                --with-modulesdir=/usr/$(get_libdir)/samba \
                --with-pammodulesdir=/$(get_libdir)/security \
                --with-piddir=/var/run/${PN} \
                --disable-rpath \
                --disable-rpath-install \
                --nopyc \
                --nopyo \
                --bundled-libraries=NONE \
                --builtin-libraries=NONE \
                $(use_with addns dnsupdate) \
                $(use_with acl acl-support) \
                $(use_with ads) \
                $(use_with aio aio-support) \
                $(use_enable avahi) \
                $(use_with cluster cluster-support) \
                $(use_enable cups) \
                $(use_with dmapi) \
                $(use_with fam) \
                $(use_enable gnutls) \
                $(use_enable iprint) \
                $(use_with ldap) \
                --with-pam \
                --with-pam_smbpass \
                $(use_with quota quotas) \
                $(use_with syslog) \
                $(use_with winbind)
                "
        use "ads" && myconf+=" --with-shared-modules=idmap_ad"

You will notice that the configure options --bundled-libraries and --builtin-libraries are set to 'NONE'

 

I set them to 'ntdb' like the Samba-4.1.6.ebuild and everything compiled fine.



#2
jorgicio

jorgicio

    Advanced Member

  • Members
  • PipPipPip
  • 58 posts
  • LocationViƱa del Mar

I still have problems with Samba 4.1.17. Now it uses ntdb as a standalone package, but when I leave the NONE in the built-in libraries in the Samba ebuild, it fails at compile.



#3
kayvax

kayvax

    Member

  • Members
  • PipPip
  • 10 posts

Same problem here. 

samba-4.0.25:

Checking for system subunit                                                                     : not found 
ERROR: System library subunit of version 0.0.0 not found, and bundling disabled
 * ERROR: net-fs/samba-4.0.25 failed (configure phase):
 *   configure failed
 * 
 * Call stack:
 *     ebuild.sh, line   93:  Called src_configure
 *   environment, line 3898:  Called waf-utils_src_configure '--enable-fhs' '--sysconfdir=/etc' '--localstatedir=/var' '--with-modulesdir=/usr/lib64/samba' '--with-pammodulesdir=/lib64/security' '--with-piddir=/var/run/samba' '--disable-rpath' '--disable-rpath-install' '--nopyc' '--nopyo' '--disable-ntdb' '--bundled-libraries=NONE' '--builtin-libraries=NONE' '--without-dnsupdate' '--without-acl-support' '--without-ads' '--without-aio-support' '--disable-avahi' '--without-cluster-support' '--enable-cups' '--without-dmapi' '--without-fam' '--disable-gnutls' '--disable-iprint' '--without-ldap' '--with-pam' '--with-pam_smbpass' '--without-quotas' '--without-syslog' '--without-swat' '--with-winbind'
 *   environment, line 4777:  Called die
 * The specific snippet of code:
 *           CCFLAGS="${CFLAGS}" LINKFLAGS="${CFLAGS} ${LDFLAGS}" "${WAF_BINARY}" "--prefix=${EPREFIX}/usr" "${libdir}" "$@" configure || die "configure failed";
 * 
 * If you need support, post the output of `emerge --info '=net-fs/samba-4.0.25'`,
 * the complete build log and the output of `emerge -pqv '=net-fs/samba-4.0.25'`.
 * The complete build log is located at '/var/tmp/portage/net-fs/samba-4.0.25/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-fs/samba-4.0.25/temp/environment'.
 * Working directory: '/var/tmp/portage/net-fs/samba-4.0.25/work/samba-4.0.25'
 * S: '/var/tmp/portage/net-fs/samba-4.0.25/work/samba-4.0.25'

samba-4.1.17:

Checking for system subunit                                                                     : not found 
ERROR: System library subunit of version 0.0.0 not found, and bundling disabled
 * ERROR: net-fs/samba-4.1.17 failed (configure phase):
 *   configure failed
 * 
 * Call stack:
 *     ebuild.sh, line   93:  Called src_configure
 *   environment, line 3903:  Called waf-utils_src_configure '--enable-fhs' '--sysconfdir=/etc' '--localstatedir=/var' '--with-modulesdir=/usr/lib64/samba' '--with-pammodulesdir=/lib64/security' '--with-piddir=/var/run/samba' '--disable-rpath' '--disable-rpath-install' '--nopyc' '--nopyo' '--bundled-libraries=NONE' '--builtin-libraries=NONE' '--without-dnsupdate' '--without-acl-support' '--without-ads' '--without-aio-support' '--disable-avahi' '--without-cluster-support' '--enable-cups' '--without-dmapi' '--without-fam' '--disable-gnutls' '--disable-iprint' '--without-ldap' '--with-pam' '--with-pam_smbpass' '--without-quotas' '--without-syslog' '--without-systemd' '--with-winbind'
 *   environment, line 4783:  Called die
 * The specific snippet of code:
 *           CCFLAGS="${CFLAGS}" LINKFLAGS="${CFLAGS} ${LDFLAGS}" "${WAF_BINARY}" "--prefix=${EPREFIX}/usr" "${libdir}" "$@" configure || die "configure failed";
 * 
 * If you need support, post the output of `emerge --info '=net-fs/samba-4.1.17'`,
 * the complete build log and the output of `emerge -pqv '=net-fs/samba-4.1.17'`.
 * The complete build log is located at '/var/tmp/portage/net-fs/samba-4.1.17/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-fs/samba-4.1.17/temp/environment'.
 * Working directory: '/var/tmp/portage/net-fs/samba-4.1.17/work/samba-4.1.17'
 * S: '/var/tmp/portage/net-fs/samba-4.1.17/work/samba-4.1.17'

eix subunit 
[I] dev-python/subunit
     Available versions:  0.0.18-r1000 {test PYTHON_ABIS="2.6 2.7 2.7-jython 2.7-pypy 3.1 3.2 3.2-pypy 3.3 3.4 3.5"}
     Installed versions:  0.0.18-r1000(17:17:04 11.03.2015)(-test PYTHON_ABIS="2.7 3.3 -2.6 -2.7-jython -2.7-pypy -3.1 -3.2 -3.2-pypy -3.4 -3.5")
     Homepage:            https://launchpad.net/subunit https://pypi.python.org/pypi/python-subunit
     Description:         Python implementation of subunit test streaming protocol

emerge --info:

emerge --info
Portage 2.3.6-r9 (funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-4.8.4, glibc-2.19, 3.19.1-gentoo x86_64)
=================================================================
System uname: Linux-3.19.1-gentoo-x86_64-Intel-R-_Core-TM-_i7-4700HQ_CPU_@_2.40GHz-with-gentoo-2.2.0
KiB Mem:    15858352 total,   4262952 free
KiB Swap:    2097148 total,   2081924 free
Timestamp of tree: Unknown
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.3_p30-r1
dev-java/java-config:     2.2.0-r1000
dev-lang/perl:            5.20.2
dev-lang/python:          2.7.9-r1000, 3.3.6-r1000
dev-util/cmake:           3.1.0
sys-apps/baselayout:      2.2.0-r6
sys-apps/openrc:          0.12.3-r6
sys-apps/sandbox:         2.6-r2
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6-r1, 1.13.4, 1.14.1
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.4
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.3-r2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.17-r1 (virtual/os-headers)
sys-libs/glibc:           2.19
Repositories: gentoo dotnet java multimedia science sage-on-gentoo pentoo gamerlay jorgicio Sylvania
Installed sets: @kernel, @radio
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA RTCW-ETEULA google-chrome Oracle-BCLA-JavaSE PUEL skype-eula skype-4.0.0.7-copyright cadsoft NVIDIA-CUDA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -O2 -pipe -mavx"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.2/conf"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7 -O2 -pipe -mavx"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync mini-manifest news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="pl_PL.utf8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
LINGUAS="pl en"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/dotnet /var/lib/layman/java /var/lib/layman/multimedia /var/lib/layman/science /var/lib/layman/sage-on-gentoo /var/lib/layman/pentoo /var/lib/layman/gamerlay /var/lib/layman/jorgicio /usr/local/portage/overlay"
SYNC="git://github.com/funtoo/ports-2012.git"
SYNC_USER="root"
USE="X acl alsa amd64 berkdb bzip2 cleartype consolekit corefonts cracklib crypt cups cxx dbus gdbm git gtk iconv icu infinality ipv6 jack jpeg libnotify lock mmx modules mudflap multilib ncurses networkmanager nls nptl nss opengl openmp pam pcre policykit pulseaudio python readline resolvconf session sse sse2 sse3 sse4 sse4_1 sse4a ssl ssse3 startup-notification subversion svg tcpd thunar truetype type1 udev unicode xattr xml zlib" ABI_X86="64" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authn_core authz_core socache_shmcb unixd" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="pl en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_ABIS="2.7 3.3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby19 ruby20 ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="nvidia intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC_UMASK



#4
Chris Kurlinski

Chris Kurlinski

    Advanced Member

  • Members
  • PipPipPip
  • 30 posts
  • LocationNassau, The Bahamas

None of the work arounds worked for me with the Samba 4.X.X ebuilds, masked the whole 4 series.

Back to Samba 3.6.25.

 

If you change None to ntdb, then I get a file collision during install.

--bundled-libraries=NONE \

--builtin-libraries=NONE \

 



#5
swamprabbit

swamprabbit

    Newbie

  • Members
  • Pip
  • 7 posts
  • LocationU.S.A.

I can confirm this issue, I just ran into it when trying to install Kodi, which pulls in Samba 4.1.17.

My system has dev-python/subunit-0.0.18-r1000.



#6
Oleg Vinichenko

Oleg Vinichenko

    Staff

  • Moderators
  • 376 posts

i don't think this is SOLVED. Until subunit package reworked.


www.funtoo.org

#7
Chris Kurlinski

Chris Kurlinski

    Advanced Member

  • Members
  • PipPipPip
  • 30 posts
  • LocationNassau, The Bahamas

Thanks for looking into it.

Doing a complete rebuild, and would like to have samba4.





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users