Jump to content

Photo

Can't obtain GNOME

installation gnome compiling

7 replies to this topic

#1
speedytux

speedytux

    Newbie

  • Members
  • Pip
  • 5 posts
  • LocationItaly

Hi, I'm a distro hopper that define himself like an Archer.

I use linux since Mandrake, like an advanced user and an administrator.

I love Gentoo, but the USE flags system overwhelming me. Funtoo is great!

 

Yesterday I wanted to try Funtoo, the boot works, X works, networking works;

but I can't install gnome-light.

 

gnome-color-manager-3.20.0 generate build error.

I tried to attach the build.log but the forum script doesn't work.


The Freedom Technologies Are Available... And Works!


#2
cardinal

cardinal

    Advanced Member

  • Members
  • PipPipPip
  • 224 posts

I created a Bug Report: gnome-extra/gnome-color-manager-3.20.0::gentoo failed (compile phase)



#3
speedytux

speedytux

    Newbie

  • Members
  • Pip
  • 5 posts
  • LocationItaly

Yes! It works now. After some emerge --sync, emerge @preserved-rebuild, emerge -uDN --with-bdeps @world ... It succeded!

 

The only problem I have now is that I should USE="-tracker" in make.conf


The Freedom Technologies Are Available... And Works!


#4
Oleg Vinichenko

Oleg Vinichenko

    Staff

  • Moderators
  • 345 posts

ok, so world update did fix this?

a problem is that  dev-perl/SGMLSpm should be present on your system. Since, it's a cross-report by another person, i'd like to have user, who actually facing a problem look in

https://bugs.funtoo.org/browse/FL-3322


www.funtoo.org

#5
speedytux

speedytux

    Newbie

  • Members
  • Pip
  • 5 posts
  • LocationItaly

Solved with the Oleg's help.

https://bugs.funtoo.org/browse/FL-3324


The Freedom Technologies Are Available... And Works!


#6
angelsystech

angelsystech

    Newbie

  • Members
  • Pip
  • 2 posts

Hey Guys, my problem consist in evolution-data-server-3.5.3 and evolution-3.5.3:

emerge: there are no ebuilds to satisfy "<gnome-extra/evolution-data-server-3.5.3".
(dependency required by "app-misc/tracker-1.6.2::gentoo[eds]" [ebuild])
(dependency required by "gnome-extra/nautilus-tracker-tags-1.6.2::gentoo" [ebuild])
(dependency required by "gnome-base/nautilus-3.18.5::gentoo[tracker]" [ebuild])
(dependency required by "app-cdr/brasero-3.12.1-r1::gentoo[nautilus]" [ebuild])
(dependency required by "media-sound/sound-juicer-3.18.2::gentoo" [ebuild])
(dependency required by "gnome-base/gnome-extra-apps-3.18.0-r1::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

I've installed evolution-data-server-3.20 and evolution-3.20 yet, but when I try to emerge gnome or @world, I receive that error... :(
Please, How can I solve that?



#7
cardinal

cardinal

    Advanced Member

  • Members
  • PipPipPip
  • 224 posts

Hey Guys, my problem consist in evolution-data-server-3.5.3 and evolution-3.5.3:

emerge: there are no ebuilds to satisfy "<gnome-extra/evolution-data-server-3.5.3".
(dependency required by "app-misc/tracker-1.6.2::gentoo[eds]" [ebuild])
(dependency required by "gnome-extra/nautilus-tracker-tags-1.6.2::gentoo" [ebuild])
(dependency required by "gnome-base/nautilus-3.18.5::gentoo[tracker]" [ebuild])
(dependency required by "app-cdr/brasero-3.12.1-r1::gentoo[nautilus]" [ebuild])
(dependency required by "media-sound/sound-juicer-3.18.2::gentoo" [ebuild])
(dependency required by "gnome-base/gnome-extra-apps-3.18.0-r1::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

I've installed evolution-data-server-3.20 and evolution-3.20 yet, but when I try to emerge gnome or @world, I receive that error... :(
Please, How can I solve that?

 
Use flag eds for tracker-1.6.2 forces reverse dependency for <mail-client/evolution-3.5.3   <gnome-extra/evolution-data-server-3.5.3
Disable eds flag from tracker-1.6.2 should enable world update.
echo "app-misc/tracker -eds" >> /etc/portage/package.use/tracker
emerge -avuDN @world

Reference: https://forums.gento...28c1de12a40692b
  • angelsystech likes this

#8
angelsystech

angelsystech

    Newbie

  • Members
  • Pip
  • 2 posts

cardinal, you save my funtoo box, man!

echo "app-misc/tracker -eds -ffmpeg gstreamer" >> /etc/portage/package.use solve my problem!

Thanks man! Thanks guys!


  • cardinal likes this



Reply to this topic



  



Also tagged with one or more of these keywords: installation, gnome, compiling

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users